aspose file tools*
The moose likes Distributed Java and the fly likes RMI Server Migration for tool Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Distributed Java
Bookmark "RMI Server Migration for tool" Watch "RMI Server Migration for tool" New topic
Author

RMI Server Migration for tool

sheeba kalarikkal
Greenhorn

Joined: May 27, 2011
Posts: 4
Hi,

Can anyone please help?!

I have a tool which makes use of RMI. JDK Version is 1.5.0_7. It was pointing to a server (Windows 2003) to get the data to this tool. But now as it's getting migrated to a new server (Windows 2008) I have to make this tool to point to the new server. I copied all the class files which were there in the old server to the new server and made the jdk version in both client and server equal (jdk1.5.0_7). Also changed the server name in the properties file to point to the new server at the client side. But the tool is not pointing to the new server.
What can I do now? I tried recompiling the source code in the server side. But that too didn't help

Thanks,
Sheeba
Andrew Monkhouse
author and jackaroo
Marshal Commander

Joined: Mar 28, 2003
Posts: 11526
    
100

You said that you recompiled the code on the server side, but did you also recompile code on the client side?

It seems logical that there is a properties file containing the server name, and therefore it should be as simple as changing that properties file. However since changing that property did not fix your problem, I would suspect that perhaps the original programmer hard-coded the server name within the client-side source files.


The Sun Certified Java Developer Exam with J2SE 5: paper version from Amazon, PDF from Apress, Online reference: Books 24x7 Personal blog
sheeba kalarikkal
Greenhorn

Joined: May 27, 2011
Posts: 4
Thanks a lot for your reply!! The server name is not hard coded . It's taking from the property file. I recompiled the code only in server side as i felt on client side there is no need of recompiling. But still it's not working.
sheeba kalarikkal
Greenhorn

Joined: May 27, 2011
Posts: 4
At Last it worked..! it was some incompatibility issues the old server was Windows 2003 and the new one was Windows 2008. The old server supported the tool in the jdk version 1.5, and we tried the same version to support in 2008. But it didn't work. When I upgraded the jdk version to 1.6, it worked fine!

Thanks & Regards,
Sheeba
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: RMI Server Migration for tool