jQuery in Action, 2nd edition*
The moose likes JSF and the fly likes Tag doesn´t works Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » JSF
Bookmark "Tag doesn´t works" Watch "Tag doesn´t works" New topic
Author

Tag doesn´t works

Dura Hurtado
Ranch Hand

Joined: Feb 16, 2011
Posts: 120
Hi, in my app i have an archive called welcome.jsf and inside the next code:


<%@ taglib uri="http://java.sun.com/jsf/html" prefix="h" %>
<%@ taglib uri="http://java.sun.com/jsf/core" prefix="f" %>

<html>
<head>
<link rel=stylesheet type="text/css" href="../estilos/estilos.css"/>
<title>ElementsH</title>
</head>
<body>
<f:view>
<h3> <hutputText value="Etiquetas de la librería H"/></h3>
<h:form id="form1" style="background-color: #EF8429;font-size: 12px;font-family: Arial, Helvetica,sans-serif;">

<code> Input SUBMIT tag</code>
<h:commandButton
id="submit"
value="Enviar"
action="nextPage">
</h:commandButton><br/><br/>



</h:form>
</f:view>
</body>
</html>


When I run the app I just can visualize Input SUBMIT tag. I mean tags are not working.

¿Anybody knows why it happend? I have in jstl-api.jar, in WEB-INF/lib.

Thanks



Guy deLyonesse
Ranch Hand

Joined: Apr 12, 2011
Posts: 200

You need to either reference your backing bean in the code (if there's some processing to do when the user clicks the button) or set up navigation rules in your faces-config.xml.

 
Consider Paul's rocket mass heater.
 
subject: Tag doesn´t works
 
Similar Threads
JSF and CSS issues
Parameter in Bean variable
Navigation problem
problem with css
Tag doesn´t works