Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Tag doesn´t works

 
Dura Hurtado
Ranch Hand
Posts: 120
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, in my app i have an archive called welcome.jsf and inside the next code:


<%@ taglib uri="http://java.sun.com/jsf/html" prefix="h" %>
<%@ taglib uri="http://java.sun.com/jsf/core" prefix="f" %>

<html>
<head>
<link rel=stylesheet type="text/css" href="../estilos/estilos.css"/>
<title>ElementsH</title>
</head>
<body>
<f:view>
<h3> <hutputText value="Etiquetas de la librería H"/></h3>
<h:form id="form1" style="background-color: #EF8429;font-size: 12px;font-family: Arial, Helvetica,sans-serif;">

<code> Input SUBMIT tag</code>
<h:commandButton
id="submit"
value="Enviar"
action="nextPage">
</h:commandButton><br/><br/>



</h:form>
</f:view>
</body>
</html>


When I run the app I just can visualize Input SUBMIT tag. I mean tags are not working.

¿Anybody knows why it happend? I have in jstl-api.jar, in WEB-INF/lib.

Thanks



 
Guy deLyonesse
Ranch Hand
Posts: 200
Eclipse IDE Java Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You need to either reference your backing bean in the code (if there's some processing to do when the user clicks the button) or set up navigation rules in your faces-config.xml.

 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic