wood burning stoves 2.0*
The moose likes I/O and Streams and the fly likes What is the encoding I should to get the polish characters correctly from request? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » I/O and Streams
Bookmark "What is the encoding I should to get the polish characters correctly from request?" Watch "What is the encoding I should to get the polish characters correctly from request?" New topic
Author

What is the encoding I should to get the polish characters correctly from request?

Jeevan Rao
Greenhorn

Joined: Jun 13, 2011
Posts: 2
I am using doPost() method in my servlet. When I am getting the input stream from request the polish characters are being corrupted like "?". Can some one please help me to resolve this issue. Do I need to pass any encoding, if yes what is it? I have tried with ISO-8859-1 and UTF-8.

Here in my application we need to support english, german and polish characters.
James Sabre
Ranch Hand

Joined: Sep 07, 2004
Posts: 781

You should use the encoding as defined in the Content-Encoding header send with the POST. Whatever is performing the POST should make sure the Content-Encoding header is set to a value that guarantees that all the Polish characters can be encoded correctly.




Retired horse trader.
 Note: double-underline links may be advertisements automatically added by this site and are probably not endorsed by me.
Jeevan Rao
Greenhorn

Joined: Jun 13, 2011
Posts: 2
Thank you very much. This issue is resolved. I am encoding with "UTF-16". Once again thank you very much for your help.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: What is the encoding I should to get the polish characters correctly from request?
 
Similar Threads
Problem with <tr:inputDate
Message bundle encoding
Reading Polish characters from database
Polish characters are gets changed to ? in websphere6.1 environment
problem with foreign characters