Granny's Programming Pearls
"inside of every large program is a small program struggling to get out"
JavaRanch.com/granny.jsp
The moose likes Tomcat and the fly likes server created in eclipse not showing welcome page of tomcat Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "server created in eclipse not showing welcome page of tomcat" Watch "server created in eclipse not showing welcome page of tomcat" New topic
Author

server created in eclipse not showing welcome page of tomcat

bhushan devare
Greenhorn

Joined: Jun 15, 2011
Posts: 12
Hello All
I am trying to deploy web application on Tomcat 6.0. I have installed tomcat on C drive in nonwhitespace directory. In browser when I am giving "http://localhost:8081/", its showing me tomcat's welcome page. In eclipse I have created server but when I am trying to browse "http://localhost:8081/" with newly created server .It is giving me HTTP status 404 error. Please help me.
Vijitha Kumara
Bartender

Joined: Mar 24, 2008
Posts: 3817

Welcome to the Ranch, Bhushan Devare!
How have you started the Tomcat once you configured the instance in Eclipse?


SCJP 5 | SCWCD 5
[How to ask questions] [Twitter]
bhushan devare
Greenhorn

Joined: Jun 15, 2011
Posts: 12
I just started it from Eclipse. Right click on sever & select start option.
Nipun Bahr
Ranch Hand

Joined: Jul 09, 2008
Posts: 55


Did you add the project before starting tomcat from eclipse?
bhushan devare
Greenhorn

Joined: Jun 15, 2011
Posts: 12
Hi Nipun. Yes, I have added the project to server
Vijitha Kumara
Bartender

Joined: Mar 24, 2008
Posts: 3817

Well, it's a normal behavior in WTP 2.0 as it uses a separate instance by default. Read more about it here. If you want to access ROOT context of your Tomcat installation you may add it under the modules of your server configuration in Eclipse.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: server created in eclipse not showing welcome page of tomcat
 
Similar Threads
HTTP Status 404 error in tomcat
http error404
start tomcat 3.3.2 in debug mode
Creating Maven web service on Netbeans and deploying on Tomcat
Error:Tomcat using ports are already being in usage by some other resources