File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Applets and the fly likes  Incompatible magic value 171712836 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Applets
Bookmark " Incompatible magic value 171712836" Watch " Incompatible magic value 171712836" New topic
Author

Incompatible magic value 171712836

maybe me
Greenhorn

Joined: Jun 10, 2011
Posts: 2
hi guys,

I got an applet wich work in my html test page but don't work once "printed" in a php page on the distant server. I don't know much about applets so i ran with purely logical test at first:
tried on several client computers : no changes
thinked it can came from the page being hosted on my computer, you know something with dependences:uploaded the html test page on free hosting and it work.
uploaded the same page on the distant server to know if it may be an error of server configuration.
Didn't work at first, so i check java ranch and figured it may came from bad uploading and it was the case.
But nothing to do about the php page it just keep not working.

html test page code:


and on the php page:



I am just out of ideas right now, so if anyone experienced anything similar to this i'd be glad to get some help.
Tell me if i should add some extra information or if you didn't get something i wrote because of my bad english.

Thank you java gurus in advance.
Madhan Sundararajan Devaki
Ranch Hand

Joined: Mar 18, 2011
Posts: 312

I am not sure, whether you can run Applets within PHP applications as Applets are based on Java.


S.D. MADHAN
Not many get the right opportunity !
maybe me
Greenhorn

Joined: Jun 10, 2011
Posts: 2
solved it turned relative


to absolute



It's weird, i thought the path was relative to the file you are in, in this case the php page echoing the "<applet>" but it seems to be relative to the generated html, wherever it may be. You may answer me that i am mistaking with client and server side but honestly sometimes it's tricky ...

Anyway quick one: It didn't find the jar.

Seriously why not an "applet not found" message...
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Incompatible magic value 171712836