aspose file tools*
The moose likes Cattle Drive and the fly likes ant can't find build.properties Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » This Site » Cattle Drive
Bookmark "ant can Watch "ant can New topic
Author

ant can't find build.properties

John Abong
Ranch Hand

Joined: May 14, 2007
Posts: 79
I decided to work over-time on the cattle drive. I'm going through each assignment at home now as well as at work. I'm all the way through to ant. Ant can't find build.properties in the user.home; build fails at deploy.

I've re-installed ant, triple-checked PATH/CLASSPATH, etc. What am I missing?

Work pc = Windows XP Pro on domain
Home pc = Windows XP Pro on workgroup
John Abong
Ranch Hand

Joined: May 14, 2007
Posts: 79
I re-checked the PATH and found two extra semi-colons at the beginning of the statement. Now the the project compiles and builds successfully but does not distribute to /orion/applications folder. Stay tuned...
Carol Murphy
village idiot
Bartender

Joined: Mar 15, 2001
Posts: 1195
Waiting with bated breath for the outcome........
John Abong
Ranch Hand

Joined: May 14, 2007
Posts: 79
~ Epilogue

I believe I have figured it out (I'll verify when i get home) and staying true to Cattle Drive form I'll try only to lead you to water...solution = WATCH YOUR PUNCTUATION!

I did find ant -diagnostics to be VERY helpful.
John Abong
Ranch Hand

Joined: May 14, 2007
Posts: 79
AS YOU WERE...

Ant Update

While I did have a punctuation issue that prevented a successfull build, the REAL issue turned out to be a flawed binary file. Re-downloading ant solved it. Case closed!
Carol Murphy
village idiot
Bartender

Joined: Mar 15, 2001
Posts: 1195
Ahhhh. A happy ending!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: ant can't find build.properties