aspose file tools*
The moose likes Jython/Python and the fly likes WebSphere Server is not in Running State :Jython WebSphere Scripting Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Languages » Jython/Python
Bookmark "WebSphere Server is not in Running State :Jython WebSphere Scripting" Watch "WebSphere Server is not in Running State :Jython WebSphere Scripting" New topic
Author

WebSphere Server is not in Running State :Jython WebSphere Scripting

Kray Var
Greenhorn

Joined: Jun 16, 2011
Posts: 1
Please find teh below code.

svr = AdminControl.completeObjectName("type=Server,*").split("\n")
print "len -- >",len(svr)
for s in svr:
print "servers are ",s

When i execute the above code ,the output doesnt show the server for which I am trying to find the running status.The output shows only server1 server though my server is running and I am able to open the apps.

But when I list the servers using the below code I find all the servers and the one which i am intersted in

servers = AdminConfig.list('Server', node).split("\n")
for server in servers:
servername = AdminConfig.showAttribute(server, 'name')
print "server name is -- ",servername

Why is this happening .
We normally start the server by the startserver.sh files and hnce tryng to automate that.The server for which I am tryng to find the status , is Running and hence I am able to open the Apps .

Any help on this ?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: WebSphere Server is not in Running State :Jython WebSphere Scripting