File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes BEA/Weblogic and the fly likes How to have Weblogic running on two IP addresses? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "How to have Weblogic running on two IP addresses?" Watch "How to have Weblogic running on two IP addresses?" New topic
Author

How to have Weblogic running on two IP addresses?

James Byars
Ranch Hand

Joined: Apr 15, 2009
Posts: 42
Hi,

My Linux box has Weblogic running on it. It also has two network interface cards, and hence has two different IP addresses. I want users to be able to access my Weblogic using either of the IP addresses. How can I do this?

Thanks.
James Byars
Ranch Hand

Joined: Apr 15, 2009
Posts: 42
James Byars wrote:Hi,

My Linux box has Weblogic running on it. It also has two network interface cards, and hence has two different IP addresses. I want users to be able to access my Weblogic using either of the IP addresses. How can I do this?

Thanks.



Sorry for bumping up, but I have waited rather long for an answer.

Can anyone help?

Thanks.
Matt Cartwright
Ranch Hand

Joined: Aug 25, 2008
Posts: 149


the default listener address is "*" or when setting it in the console or via JMX, an empty string ("").
This will cause the WL Server instance to listen on all available interfaces on that box.

So, if you have a listen address specified, just replace it with an empty String.
When using the console, just leave that field blank, save and activate, then restart...

If you want to listen only on dedicated interfaces, configuring channels is the way forward.

Hope that helps.
Matt
James Byars
Ranch Hand

Joined: Apr 15, 2009
Posts: 42
Matt Cartwright wrote:
the default listener address is "*" or when setting it in the console or via JMX, an empty string ("").
This will cause the WL Server instance to listen on all available interfaces on that box.

So, if you have a listen address specified, just replace it with an empty String.
When using the console, just leave that field blank, save and activate, then restart...

If you want to listen only on dedicated interfaces, configuring channels is the way forward.

Hope that helps.
Matt




Thanks, Matt, yes, that worked
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: How to have Weblogic running on two IP addresses?
 
Similar Threads
Geting exeption in JNDI
Fetching all ip addresses in LAN
Linux and Windows Networking
weblogic license error, Invalid host IP
Binding tomcat to non-localhost address