jQuery in Action, 2nd edition*
The moose likes IDEs, Version Control and other tools and the fly likes Eclipse IDE Must Have the Most Recent Version of JDK Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Eclipse IDE Must Have the Most Recent Version of JDK" Watch "Eclipse IDE Must Have the Most Recent Version of JDK" New topic
Author

Eclipse IDE Must Have the Most Recent Version of JDK

Natalie Kopple
Ranch Hand

Joined: May 06, 2003
Posts: 325
I configured the Eclipse quite some time ago; therefore, the JDK/JRE I have been using is not the most recent version.

Lately, I downloaded some most recent web services and XSL JARs for a new project and ran into imcompatible using combination of JARs problem.

I have downloaded the JDK 1.6.0. What do I do with the Eclipse?

Do I go to the Project --> Properties --> Build Path --> Libraries and remove the existing JRE and then click on the "Add External JARs" and browse to C:\Program Files\Java\jdk1.6.0\bin? Or there is a better way to do it?

Thank you.
David Byron
Rancher

Joined: Jan 20, 2009
Posts: 171

Natalie Kopple wrote:I have downloaded the JDK 1.6.0. What do I do with the Eclipse?

Do I go to the Project --> Properties --> Build Path --> Libraries and remove the existing JRE and then click on the "Add External JARs" and browse to C:\Program Files\Java\jdk1.6.0\bin? Or there is a better way to do it?


Maybe go to Window --> Preferences --> Java --> Installed JREs --> Add to select the location of the new runtime (probably C:\Program Files\Java\jre6), and then rightclick on your project node, choose Properties, and ensure that the Java Compiler settings are correct.
Natalie Kopple
Ranch Hand

Joined: May 06, 2003
Posts: 325
Thanks very much for guidance. I appreciate it.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Eclipse IDE Must Have the Most Recent Version of JDK
 
Similar Threads
How to set different JDKs for different projects in Eclipse 3.0.1?
Tomcat plugin for Eclipse installed, but no "Tomcat Project" in the menu
how to add API document to eclipse
WTP in Eclipse