wood burning stoves 2.0*
The moose likes XML and Related Technologies and the fly likes JAXB2 and JDK 1.6.0 Compatibility Problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » XML and Related Technologies
Bookmark "JAXB2 and JDK 1.6.0 Compatibility Problem" Watch "JAXB2 and JDK 1.6.0 Compatibility Problem" New topic
Author

JAXB2 and JDK 1.6.0 Compatibility Problem

JiaPei Jen
Ranch Hand

Joined: Nov 19, 2000
Posts: 1309
If I am not terribly wrong, JAXB2 works with JDK 1.5.X.

When I use JDK 1.6.0 with JAXB2, I run into many problems.

If any Java Rancher knows how to get around the problems, please post solutions. Thank you.
g tsuji
Ranch Hand

Joined: Jan 18, 2011
Posts: 511
    
    3
If you're using jaxb from within the jwsdp-2.0 download, then I'm afraid you have to make an addition download of the newest jaxb ri. It is 2.2.1 the last time I looked at it. The jaxb-xjc.jar that came with the jwsdp-2.0 is wrongly bundled with a beta that's why. Use the latest download to replace the jaxb that came with it.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JAXB2 and JDK 1.6.0 Compatibility Problem