• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

session problem

 
sudharshan tettu
Ranch Hand
Posts: 126
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
IN my struts applicaton i have a series of 5 pages

i am setting one attribute to session on 2 page and retrieving it on 3,but when i navigate to 4 page and get back to 3 ,its showing error like the element is not found in the session..
but it works well from 2 to 3...
any help pls
 
Merrill Higginson
Ranch Hand
Posts: 4864
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Once you put something in the session it stays there unless one of the following occurs:

1-The session times out
2-The session is invalidated with session.invalidate()
3-The attribute is removed with session.removeAttribute("myBean")

You might want to check whether there are name conflicts. One action may be inadvertently setting or clearing a session attribute using the same name as the one you're having problems with.
 
Ben Souther
Sheriff
Posts: 13411
Firefox Browser Redhat VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Since you're using Struts,
I'm going to move this thread to our Struts forum.

There may be things specific to that framework that need to be considered.
 
sudharshan tettu
Ranch Hand
Posts: 126
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thank you....for ur quick reply
its working now..its a name conflict..occured over the pages..
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic