File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JSF and the fly likes 404 error loading Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Java » JSF
Bookmark "404 error loading" Watch "404 error loading" New topic
Author

404 error loading

Varun Nayudu
Ranch Hand

Joined: Jun 26, 2006
Posts: 157
Hi,
I have just starting using JSF. I made a simple web application using Apache tomcat. I made a index.jsp as the welcome page and configured it in the web.xml.
It works fine till here . Then since i wanted to introduce JSF in the web application i added jsf-api.jar in the lib folder of the web application . Till here it worked fine , but as soon as i introduced jsf-impl.jar in the lib folder it gave a '404 Error' .

I would appreciate if any one can tell me why by just introducing jsf-impl.jar in the lib folder would i get this error.
Regards


SCJP 1.5, SCWCD 1.5
Varun Nayudu
Ranch Hand

Joined: Jun 26, 2006
Posts: 157
Guys ,

I was able to resolve this issue I just had to add the el-api.jar in the lib folder .
Varun Nayudu
Ranch Hand

Joined: Jun 26, 2006
Posts: 157
Hi guys

This would real dum but i have still not been able to resolve this issue. I m using Eclipse 3.3, jdk 5, and jsf 1.2.

I know in my last post i had said that i had resolved the issue but now its again cripped in . The shocking thing is even after putting in the el-api.jar i still get the same error.

Error 1: On the page i get the following error



Error 2 : In the tomcat log i get the following error





Application directory structure is send with attachment...



[Thumbnail for Leftmenu.png]

 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: 404 error loading
 
Similar Threads
package com.sun.faces.taglib.html_basic does not exist
unable to instantiate tag f:view
Upgrade
Deploy JSF 1.2 application on JBoss 5.1.0 GA
Unable to load primefaces-2.0.0.jar on Weblogic Start Up.