wood burning stoves 2.0*
The moose likes Tomcat and the fly likes why dosen't my web application on tomcat see the correct lib file? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "why dosen Watch "why dosen New topic
Author

why dosen't my web application on tomcat see the correct lib file?

migue abre
Greenhorn

Joined: Jun 26, 2011
Posts: 7
hello guys im a noob to tomcat, and pretty new to java. I just deployed an application onto my linux server all done through eclipse IDE. however when i put all the files on the Tomcat it dosent see them in other words. i have to put all my jar files under the root of the tomcat install in order for my application to see them? i dont get it. ive been reading that every application needs to have its own web.xml and web-inf directory. wich my has. however the only way my application works is if i litterally put all my jar files in the root/web-inf folder? can someone give me a hint on what i might be doing wrong. why dosent the application default to webapps/learn/web-inf which is where mine is located. I would appreciate any help.
Thanks
Miguel
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 60059
    
  65

The jar files need to be placed in the WEB-INF/lib folder of the web app. Not web-inf. Case counts.


[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
migue abre
Greenhorn

Joined: Jun 26, 2011
Posts: 7
Bear Bibeault wrote:The jar files need to be placed in the WEB-INF/lib folder of the web app. Not web-inf. Case counts.

sorry i should have mentioned that i just didnt capitalize here. everything is onthe WEB-INF as you stated. Any other suggestions?
Miguel
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 60059
    
  65

Please read AvoidRedHerrings.

I said WEB-INF/lib not WEB-INF.
migue abre
Greenhorn

Joined: Jun 26, 2011
Posts: 7
Bear Bibeault wrote:Please read AvoidRedHerrings.

I said WEB-INF/lib not WEB-INF.



thanks for the article and i apologize i was not clear to begin with sometimes frustuation gets the best of me. Im sure you understand.
Anywho. i have the Jars in WEB-INF/lib already and im working with Tomcat 5.5. im not sure why the application is not working as it supposed to. the funny thing is that if i move the files from my
WEB-INF/lib to the ROOT/WEB-INF/lib the application works...? I'm just not sure why this could be?

thanks
Miguel
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 60059
    
  65

Apparently your Tomcat structure is messed up because somehow your app and the root app are mixed up. How did you set up the folder structure of your web app.
migue abre
Greenhorn

Joined: Jun 26, 2011
Posts: 7
Bear Bibeault wrote:Apparently your Tomcat structure is messed up because somehow your app and the root app are mixed up. How did you set up the folder structure of your web app.

well i hope im answering this question correctly but basically my application is set up as follows
TomcatInstall/webapps/ROOT/Learn/WEB-INF/lib has all my jars
TomcatInstall/webapps/ROOT/Learn/.classpath
is this what you are asking me?
Miguel
migue abre
Greenhorn

Joined: Jun 26, 2011
Posts: 7
I'm such an idiot your last post gave me the final clue. I'm placing my files under the ROOT directory when they should be placed under the webapps directory. this was my problem all along. gosh what an idiot I'm.
Thanks for your help.
Miguel
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: why dosen't my web application on tomcat see the correct lib file?
 
Similar Threads
Exception: com.microsoft.jdbc
Class NOT FOUND in Tomcat
Where to put JSTL .jar files?
Running an Applet in Tomcat 4.0
web application not visible.