aspose file tools*
The moose likes Beginning Java and the fly likes version 1.4.2_03 of the jvm is not suitable for this product. 1.5 or greater is required problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Java » Beginning Java
Bookmark "version 1.4.2_03 of the jvm is not suitable for this product. 1.5 or greater is required problem" Watch "version 1.4.2_03 of the jvm is not suitable for this product. 1.5 or greater is required problem" New topic
Author

version 1.4.2_03 of the jvm is not suitable for this product. 1.5 or greater is required problem

Adnan Gondal
Ranch Hand

Joined: Apr 30, 2011
Posts: 32
Today i installed windows xp 2002 service pack2, eclipse was working fine on previous same window but now when i run eclipse it gives "version 1.4.2_03 is not suitable for this product.1.5 or greater is required" message and does not run. For checking my version of jvm, i visited java.com and clicked upon free java download button, it verified that i am having recommended java installed(1.6.0_27-ea) but eclipse is giving above mentioned message.Kindly tell me that what should i do?

Thanks in advance
Jesper de Jong
Java Cowboy
Saloon Keeper

Joined: Aug 16, 2005
Posts: 13868
    
  10

Do you maybe have Oracle database software installed on your system? Some versions come included with a Java 1.4 JRE. Maybe Eclipse is picking that up instead of your Java 6 JRE.

When you type java -version on the command line, then what version does it show?

Modify your PATH environment variable so that Java 6 is first in the PATH, before any Java 1.4 installation.


Java Beginners FAQ - JavaRanch SCJP FAQ - The Java Tutorial - Java SE 7 API documentation
Scala Notes - My blog about Scala
Rob Spoor
Sheriff

Joined: Oct 27, 2005
Posts: 19541
    
  16

Jesper de Jong wrote:Do you maybe have Oracle database software installed on your system? Some versions come included with a Java 1.4 JRE.

Or worse, a Java 1.3 JRE...


SCJP 1.4 - SCJP 6 - SCWCD 5 - OCEEJBD 6
How To Ask Questions How To Answer Questions
Walter Gabrielsen Iii
Ranch Hand

Joined: Apr 09, 2011
Posts: 158
Can you go into Eclipse's preferences, like you can in NetBeans, and see which directory and packages are registered with Java (SE I assume?)?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: version 1.4.2_03 of the jvm is not suitable for this product. 1.5 or greater is required problem
 
Similar Threads
Where to download the correct JVM
Problem working with eclipse
Version conflict for eclispe ?
Issues with Ecllipse
Incompatible JVM error