aspose file tools *
The moose likes Web Services and the fly likes Module Rampart in Tomcat ClassNotFoundException Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Web Services
Bookmark "Module Rampart in Tomcat ClassNotFoundException" Watch "Module Rampart in Tomcat ClassNotFoundException" New topic
Author

Module Rampart in Tomcat ClassNotFoundException

Douglas Mendonca
Greenhorn

Joined: Mar 26, 2010
Posts: 7
Hi guys, I tried to deploy the rampart module in Tomcat and I face this error:



I search this class and I found in apache-tomcat-7.0.12\webapps\axis2\WEB-INF\lib\axis2-kernel-1.6.0.jar

My versions:
rampart-1.6.0
apache-tomcat-7.0.12
axis2-1.6.0

My steps:
1. I copied all jar from rampart-1.6.0\lib to apache-tomcat-7.0.12\webapps\axis2\WEB-INF\lib\
2. I copied the rampart-1.6.0.mar to apache-tomcat-7.0.12\webapps\axis2\WEB-INF\modules

But I tried start tomcat, the same error alway appear:


What am I doing wrong?

Thanks!
Kristofor Davison
Greenhorn

Joined: Jul 05, 2011
Posts: 6
Seems correct to me I did the same thing this morning.
have you tried getting a new version of rampart in case your download was corrupt?
or maybe it is your tomcat which is having problems?

or you could un-deploy axis2 and try again from scratch it is a quick process anyway.

have you had normal insecure web services running on axis already?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Module Rampart in Tomcat ClassNotFoundException