aspose file tools*
The moose likes JSP and the fly likes Bean property isn't setting Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Java » JSP
Bookmark "Bean property isn Watch "Bean property isn New topic
Author

Bean property isn't setting

Charessa Reilly
Ranch Hand

Joined: May 26, 2011
Posts: 39
(it's almost been a week! Did you miss me?)

so my jsp uses this code:


the setter in the InquireRecord class:


the output:
the value is:


I'm not getting any errors anywhere. it's just not setting that property. Any ideas? (in other words, what typo and major misconception do I have this time?)
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61419
    
  67

A few things:
  • The setProperty action is quaint. You already know about <c:set>, why use setProperty at all?
  • Does a bean of that name already exist? The content of the useBean only executes when a new bean is created.


  • [Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
    Charessa Reilly
    Ranch Hand

    Joined: May 26, 2011
    Posts: 39
    I... hadn't realized I could use c:set. I thought it was just for jsp variables, not bean interaction.

    but after a little research, I tried that and it worked

    Thanks!

    (no, there weren't any other beans with that name)
     
    I agree. Here's the link: http://aspose.com/file-tools
     
    subject: Bean property isn't setting