Meaningless Drivel is fun!*
The moose likes Web Services and the fly likes a new method is added to the old wsdl file causing issue Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "a new method is added to the old wsdl file causing issue" Watch "a new method is added to the old wsdl file causing issue" New topic
Author

a new method is added to the old wsdl file causing issue

GeethGubi Gubendran
Greenhorn

Joined: Jul 31, 2006
Posts: 26
We are using netbeans. Also we are using methods from a webservice. We generated all the client files and checked in those client files and dont regenerate all the time and the code was working fine. Recently, a new method was added to a webservice. I regenerated all the client files again. But we are not using the new method in our code. but it is there in the client file generated.

My assumption is we dont need to use all the methods that are available in the webservice. It should work fine as long as the wsdl and client files are having exactly whatever new method has been added to the webservice.

My build is working fine. During the server run, I am getting the below error.


error: in binding "SecurityServiceEndPoint", operation "newMthod" does not match any operation in the corresponding port type
DPL5035:Error while running ejbc

Can someone help me to resolve this issue?

Thanks,
Geetha

Cheers,<br />Geetha
Aj Maven
Greenhorn

Joined: Jul 04, 2011
Posts: 22

Are you using the newly generated method in the client side code ?
In that case, please check if the method parameters are correct.


Thanks
-Aj
GeethGubi Gubendran
Greenhorn

Joined: Jul 31, 2006
Posts: 26
I am not using that method in my client code. after regenerating, the stubs got updated with the newly generated method. But in my client I dont need that method
 
 
subject: a new method is added to the old wsdl file causing issue
 
Similar Threads
Invoking a https webservice
Response Contained No Data Exception
Changeing the WDSL effect on WebService consumer
Struggling with use of my Webservice from PHP client.
WSDL