Meaningless Drivel is fun!*
The moose likes Tomcat and the fly likes Cannot connect in https Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Cannot connect in https" Watch "Cannot connect in https" New topic
Author

Cannot connect in https

Alan Melrose
Greenhorn

Joined: Jan 15, 2011
Posts: 5
Hi,
I seen a few post about that and also a few solution with a google search but none as worked for me.
I get this when I try to connect to me tomcat in https:

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)


This is the ssl connector part of my server.xml:


Any Help would be appreciated
Thanks
Alan Melrose
Greenhorn

Joined: Jan 15, 2011
Posts: 5
Anyone?
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 15964
    
  19

You typically get this message when you have a mismatch between the protocol that your client is using and the protocol that the server is expecting; usually sending HTTP to an HTTPS listener.

Search back in this forum a week or 2, however, and there's another thread on this subject that should be of interest to you.


Customer surveys are for companies who didn't pay proper attention to begin with.
Ravinderjit Singh
Ranch Hand

Joined: Jan 13, 2010
Posts: 70
You have to specify the protocol in 'server.xml'.

Check out this post.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Cannot connect in https
 
Similar Threads
http to https redirect jboss 5.0.1 GA
enable https on jboss 5
Tomcat and https on Windows 7
How to enable SSL for only one site in Tomcat
Configure https