This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes Ant, Maven and Other Build Tools and the fly likes Nexus doesn't index artifacts when using scp to deploy Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Engineering » Ant, Maven and Other Build Tools
Bookmark "Nexus doesn Watch "Nexus doesn New topic
Author

Nexus doesn't index artifacts when using scp to deploy

Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5812
    
    7

I have set up my POM to use scp to deploy artifacts to my Nexus-managed repository as mentioned here:
http://maven.apache.org/plugins/maven-deploy-plugin/examples/deploy-ssh-external.html

I have noticed that when I do this, Nexus does not index the artifact, which names searching within Nexus a hit-or-miss proposition. Has anyone else run into this and if so, what did you do to get around this?

I suspect that I could make a call to the Nexus REST API to do the indexing, but no specific API call has stood out to accomplish this. Any hints of API calls or scripts to tell Nexus to add an item to the index would help.

Currently we have a cron job that rebuilds the index about every hour, but that is somewhat processor and disk intensive and we are hoping for a lighter-weight solution.


JBoss In Action
 
Don't get me started about those stupid light bulbs.
 
subject: Nexus doesn't index artifacts when using scp to deploy
 
Similar Threads
m2Eclipse + Nexus deploy:deploy problem
Maven chokes on large artifacts
Maven, Nexus, Jenkins and transition between development and release
Could not resolve dependencies for maven project
Maven Local repository Vs nexus