Get your CodeRanch badge!*
The moose likes BEA/Weblogic and the fly likes Weblogic Connection Pool Issue Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Weblogic Connection Pool Issue" Watch "Weblogic Connection Pool Issue" New topic
Author

Weblogic Connection Pool Issue

Muhammad Imad Qureshi
Ranch Hand

Joined: Sep 13, 2005
Posts: 238
Hi

We have a weblogic server. We have following settings in our connection pool. The problem we are haing is that the connection pool is apparently giving stale connections (or so we think). Do you see anything that we can improve in the following xml file?

Thanks for your help
Imad

Pazhanikanthan Periasamy
Greenhorn

Joined: Jul 18, 2011
Posts: 9
1. What verison of WebLogic server are you using?
2. What do you mean by stale?
Muhammad Imad Qureshi
Ranch Hand

Joined: Sep 13, 2005
Posts: 238
1. We are using 10.3

2. By stale I mean connection that is not good. We get connection closed error. Although the property "test connection on reserve" is "true". I also see in my database "select count(*) from dual" query run by weblogic user very often. And this connection drop happens only occasionally. Let's say two or three times a day. But it must be fixed. It may not be weblogic and something else (perhaps cluster or the driver), but I need to prove that. Any help is really appreciated.

Thanks
Imad
Debasis Dana
Greenhorn

Joined: Jul 21, 2011
Posts: 5
check the DB connection pool and monitor the no of connection constantly and check the no of connection.this might be this type of issue. also check the code if connections are released corrctly.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Weblogic Connection Pool Issue
 
Similar Threads
CDATA problem???
Problem starting JBOSS 4.2.3
problem while starting jboss5.0
jboss, datasource naming and lookup error
JNDI Port number issue while strating JBoss server 4.2.2.GA