File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Struts and the fly likes Struts 1 Validator Not Working After Migrating to WAS 7.0 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Struts 1 Validator Not Working After Migrating to WAS 7.0" Watch "Struts 1 Validator Not Working After Migrating to WAS 7.0" New topic
Author

Struts 1 Validator Not Working After Migrating to WAS 7.0

K Reiss
Greenhorn

Joined: Jul 21, 2011
Posts: 1
All of out struts applications have been written in struts 1. We are currently migrating all of our applications from WAS 6.0 to WAS 7.0. The struts validation in the applications are no longer working when the apps are deployed on WAS 7.0. When we manually write or validations its fine, but when we rely on the validation.xml and validator-rules.xml the validation does not work...it shows no errors or writes nothing to the logs as well.

In testing one of the applications we imported the latest struts jar files into the lib folder and this has corrected the validation problem....However I have a hard time believing this is the only way to correct this issue b/c this means we have to do this for every project and when we migrate servers in the future we're back to square 1.

I'm thinking maybe there's a setting on the WAS 7.0 server to be backwards compatible with the struts validation...

Any advise, help is appreciated.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Struts 1 Validator Not Working After Migrating to WAS 7.0