wood burning stoves 2.0*
The moose likes JBoss/WildFly and the fly likes Jboss configuration issue Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Jboss configuration issue" Watch "Jboss configuration issue" New topic
Author

Jboss configuration issue

vip singh
Greenhorn

Joined: Jul 23, 2011
Posts: 2
I Have a very strange issue while creating build .First will explain the project structure after that main problem.

Development Environmet :
IDE: eclipse
Server:Jboss 4.2.3GA

I have created three web Dynamic project(WDP),and one Enterprise application project (EAP)and link all three (WDP) with this project.
Scenario 1):
I configured Jboss with EAP, create build using publish option on Jboss.Build create successfully but Application does’nt run.

Scenario 2):
When I configure EAP with the Jboss server I copies from server(Where application is running fine)
On my local machine. Application runs fine ,but using this server I am not able to create build. One intresting thing with this scenario is ,there is no .ear file in this server still application running fine.

Only customized setting in Jboss I m using is that I make a copie of default folder inside server and rename to the name of EAP.

Any one has some clue about this problem
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5779
    
    7

Vip, welcome to Java Ranch!

Let's try doing this without Eclipse and get your application running first. This way we won't have to worry about Eclipse being "helpful" and just messing things up.

So do this, build your application (you can use Eclipse for this is you like). Then start JBoss AS manually from the command line. Then copy the EAR file to the deploy directory within JBoss AS. Let me know if that works. If it doesn't, post the first exception stack trace from the console log.

I really am not understanding scenario 2. Are you saying that you deploy the EAR to a remote host running JBoss AS? Or just the WAR files? Once again, doing this without Eclipse being involved and instead telling me what you did manually would greatly help.


JBoss In Action
vip singh
Greenhorn

Joined: Jul 23, 2011
Posts: 2
Hi Peter ,

I have resolved this configuration issue..by some other alternate....but m still amaze of second scenario....

Thanks for your solution..
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Jboss configuration issue
 
Similar Threads
Jboss EAP instances not detected by JON 2.4.1
can any body find this error
Jax-ws client deploy stucked
Some errors are throwing on JBOSS cluster.
The website declined to show this webpage