GeeCON Prague 2014*
The moose likes Java in General and the fly likes Java Production Issue Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Java » Java in General
Bookmark "Java Production Issue" Watch "Java Production Issue" New topic
Author

Java Production Issue

sydubabu vasantha
Greenhorn

Joined: Jul 25, 2011
Posts: 1
Hi,
I have a high priority production Issue.
In my application I am using Hibernate framework oracle 10g. daily I am running a job at 8PM to get data from database to generate a report.
Here job is nothing but a java class. Everyday I am running a job to get data between yesterday's 7:30 PM to today 7:30 pm. Here the problem is everyday I am missing the data at 12AM to 1 AM This problem is in Production only If I am doing same thing on dev regions it's working fine. One more update is from my local workspace I connected to Production datatbase and run the job locally I am getting the entire data without missing any data. I dont know it's a database issue or java code issue or environment issue.
Here is the code I used to get the data


Any one please help me on this.
Wouter Oet
Saloon Keeper

Joined: Oct 25, 2008
Posts: 2700

Hi and welcome to the JavaRanch.

If you run the same code with different results on dev and production then it is probably a configuration issue.


"Any fool can write code that a computer can understand. Good programmers write code that humans can understand." --- Martin Fowler
Please correct my English.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Java Production Issue