aspose file tools*
The moose likes IDEs, Version Control and other tools and the fly likes Error starting tomcat in eclipse Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Error starting tomcat in eclipse" Watch "Error starting tomcat in eclipse" New topic
Author

Error starting tomcat in eclipse

n nados
Greenhorn

Joined: Jul 26, 2011
Posts: 3
Hello,

I am getting this error when starting tomcat.

Any idea what's going on? A jar I'm missing in my build bath? I'm using eclipse indigo and apache-tomcat-6.0.16

16:27:21,027 ERROR [main] com.documentum.web.common.Trace - An error occurred during application intialization : org/eclipse/emf/ecore/resource/ResourceSet
java.lang.NoClassDefFoundError: org/eclipse/emf/ecore/resource/ResourceSet
at com.documentum.services.preset.impl.PackageDefinitionLoader.loadPackageDefinitionFromFile(PackageDefinitionLoader.java:117)

Thanks
Vijitha Kumara
Bartender

Joined: Mar 24, 2008
Posts: 3825

Welcome to the Ranch!

Are you starting Tomcat from Eclipse? What changes have you done to the configurations?


SCJP 5 | SCWCD 5
[How to ask questions] [Twitter]
n nados
Greenhorn

Joined: Jul 26, 2011
Posts: 3
Thank you!

I am indeed starting Tomcat from within Eclipse. The changes I have made was creating a new dynamic project, added required classes to the build bad and that's pretty much it.

I believe the org.eclipse.emf.ecore.resource.ResourceSet is missing but I'm not sure why.


Vijitha Kumara wrote:Welcome to the Ranch!

Are you starting Tomcat from Eclipse? What changes have you done to the configurations?
n nados
Greenhorn

Joined: Jul 26, 2011
Posts: 3
OK I fixed the problem.

I had my libraries added to the buildpath but not the classpath in the run configuration in eclipse.




n nados wrote:Thank you!

I am indeed starting Tomcat from within Eclipse. The changes I have made was creating a new dynamic project, added required classes to the build bad and that's pretty much it.

I believe the org.eclipse.emf.ecore.resource.ResourceSet is missing but I'm not sure why.


Vijitha Kumara wrote:Welcome to the Ranch!

Are you starting Tomcat from Eclipse? What changes have you done to the configurations?
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
 
subject: Error starting tomcat in eclipse