aspose file tools*
The moose likes Oracle/OAS and the fly likes Error 1045 while installing MySQL Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Products » Oracle/OAS
Bookmark "Error 1045 while installing MySQL" Watch "Error 1045 while installing MySQL" New topic
Author

Error 1045 while installing MySQL

pramod talekar
Ranch Hand

Joined: Apr 26, 2010
Posts: 323

Hello,

I'm getting 'Error Nr. 1045 -Access denied for user 'root'@localhost' (using password:YES)

It seems that I messed up while setting up root password,
I've uninstalled it many times to have a clean installation by removing it from add/remove in control panel, then deleting the service and deleting the folder in Program files.

It also seems that during new installation, if I don't enter existing root password, it shows me the same error but with (using password:NO).

I've searched many forums but nothing happened.
So finally Java Ranch
Please advise.


Thanks,
Pramod
Vijay Tidake
Ranch Hand

Joined: Nov 04, 2008
Posts: 146

Hi pramod,

Which OS are you you using?

if you are using Microsofts OS then while installing the MySQL disable the firewall first and add the port exception to firewall after installation.

Thanks


The important thing is not to stop questioning.Curiosity has its own reason for existing.
pramod talekar
Ranch Hand

Joined: Apr 26, 2010
Posts: 323

Hi Vijay,

Ok, I'm using Win XP.

Trying..will let you know.

Thanks for the help.
pramod talekar
Ranch Hand

Joined: Apr 26, 2010
Posts: 323

Now I'm getting the new error Could not start the service MySQL3 : Error 0.

First I deleted the existing service MySQL,
Then during fresh installation, I tried giving names like MySQL, MySQL2 etc. but it showed error for every name.]
And yes I checked the option of add firewall exception to this port.
pramod talekar
Ranch Hand

Joined: Apr 26, 2010
Posts: 323

I read somewhere that in order to do the complete uninstallation, one needs to delete the file under "Program files" and then proceed with add/remove menu.
I'm trying to do that. Meanwhile during first try, I got the service can not start error. So I changed the service name and unchecked the box for setting password.
(It doesn't ask for existing root password though)

And now after 15 mins, I'm still getting the processing configuration window.

pramod talekar
Ranch Hand

Joined: Apr 26, 2010
Posts: 323

Got the solution guys !!!

While trying to install MySQL instance, I deleted almost everything I could see e.g. a folder in Program files, searched any entry starting with MySQL in the Search option and deleted them as much as possible. Also cleared the registry and deleted MySQL service again n again. All this didn't work.This happened for weeks.

And then I checked the machine of my friend who successfully installed it and found out that there is a folder called Application Data in Documents & settings/All users and this folder contained MySQL folder with two previously installed instances.
Deleted them and now I'm a happy user
Astha Sharma
Ranch Hand

Joined: Oct 15, 2011
Posts: 249

It worked for me too
thanks prompd


Astha - OCPJP 6 (90%)
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Error 1045 while installing MySQL