File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Unable to setup eclipse for remote debugging with Weblogic 9.3

 
Neo Mat
Greenhorn
Posts: 2
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Experts,

I am facing the same problem.
I have added the following line in statWeblogic.sh file:
view plaincopy to clipboardprint?
JAVA_OPTIONS="-Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,address=1044,suspend=n -Xdebug -Xnoagent ${JAVA_OPTIONS}"
JAVA_OPTIONS="-Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,address=1044,suspend=n -Xdebug -Xnoagent ${JAVA_OPTIONS}"

Also after starting weblogic server in the black window i can see following log message:

After this i tried creating a new Debug Config by using Eclipse. I did following to create Debug Config:
1. Provided ip address of weblogic server under Connection Properties-->Host
2. Provided 1044 under Connection Properties-->Port
3. Click on "Apply" button and "Close"
4. Open Debug perspective and "Debug" the newly created configuration.

I am getting following Error:

I have already taken care of following:
1. Make sure that code in eclipse and jar deployed on weblogic server are in synch.
2. As I am using Operating System as Windows 2000 Professional. No problem of Firewall settings.

Following are the details of my environment:
1. Windows 2000 Professional - client machine where my eclipse is located
2. Eclipse Galileo
3. Java 1.6
4. Weblogic 9.3 on Linux server pack

Please help me, I am unable to find out the exact root cause.
Thanks for your help and cooperation.
 
Totally lost
Greenhorn
Posts: 1
Eclipse IDE Java Tomcat Server
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Some points to check:
1. Are you able to ping the application from the machine where eclipse is installed?
2. Hope the code deployed is compiled with the option [ debuglevel="lines,vars,source" ]
3. JRE versions on the Weblogic and eclipse host machines should match
4. Try restarting your eclipse with -clean option

 
Carol Enderlin
drifter
Ranch Hand
Posts: 1364
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
We use the Oracle Enterprise Pack for Eclipse
 
I agree. Here's the link: http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic