aspose file tools*
The moose likes JBoss/WildFly and the fly likes Jboss-common-client.jar conflict Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Jboss-common-client.jar conflict" Watch "Jboss-common-client.jar conflict" New topic
Author

Jboss-common-client.jar conflict

usman mir
Greenhorn

Joined: Aug 04, 2011
Posts: 5
Hello,
I have an application built in Spring, deployed on jboss. datasource is defined in a mssql file in jboss/seerver/default/deploy directory. It runs fine.

There is a web service deployed on jboss as well. When my application tries to access the web service, i encounter a ClassNotFoundException for org/jboss/logging logger class. I tried to add the jboss-common-client.jar to my classpath. but when i did i got some jar conflict and at server startup, i started getting jndi exception as if there is no object bound with my datasource name.

I am using jboss-4.2.0.GA


The libs in my classpath are
<classpath>
<classpathentry kind="src" path="src"/>
<classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/jdk1.6.0_18"/>
<classpathentry kind="con" path="melibrary.com.genuitec.eclipse.j2eedt.core.MYECLIPSE_JAVAEE_5_CONTAINER"/>
<classpathentry kind="con" path="org.eclipse.jst.j2ee.internal.web.container"/>
<classpathentry kind="con" path="org.eclipse.jst.j2ee.internal.module.container"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/antlr-2.7.6.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/asm.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/cglib-2.2.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/commons-collections-2.1.1.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/commons-logging.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/dom4j-1.6.1.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/ejb3-persistence.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/fscontext.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/hibernate-annotations.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/hibernate-commons-annotations.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/hibernate-entitymanager.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/hibernate-validator.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/hibernate3.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/jstl-standard.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/jstl.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/jta.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/log4j-1.2.11.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/msbase.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/mssqlserver.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/msutil.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/persistence.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/spring-beans.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/spring-context.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/spring-core.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/spring-jdbc.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/spring-orm.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/spring-tx-2.5.5.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/spring-web.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/spring-webmvc.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/sqljdbc4.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/xerces-2.6.2.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/xml-apis.jar"/>
<classpathentry kind="lib" path="C:/Documents and Settings/usman.tahir/Desktop/libs/sso-client.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/xstream-1.3.1.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/spring-ws-core-1.5.4.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/spring-xml-1.5.4.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/spring-oxm-1.5.4.jar"/>
<classpathentry kind="lib" path="WebContent/WEB-INF/lib/saaj-impl-1.3.2.jar"/>
<classpathentry kind="output" path="WebContent/WEB-INF/classes"/>
</classpath>


Can any one help me to identify what is causing this conflict? I will be GREATFUL.


Regards,
Usman



usman mir
Greenhorn

Joined: Aug 04, 2011
Posts: 5
If I have not provided sufficient information, kindly let me know. I have wasted many days on this issue already.

Regards,
Usman
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5843
    
    7

usman, welcome to Java ranch!

I do not understand where <classpath> is defined. That is not a standard JBoss AS setting.

I also don't understand org.jboss.logging.Logger cannot be found since that is part of JBoss AS and thus should be in the classpath for your app automatically, assuming your application is a WARE, EAR or something else like that. Exactly what kind of application is this?

Also, it is usually best to provide the complete stack track rather than just the error message.


JBoss In Action
usman mir
Greenhorn

Joined: Aug 04, 2011
Posts: 5
Hello Peter,
Many thanks for replying.
Its actually a simple Spring 3 controller based application(no EJBs) built using MyEclipseForSpring 9. The classpath I sent is the file created by MyEclipse for the project. I thought it would be useful for some one to point out any conflict if there is any among the jars.

Unfortunately, I know very little about the web service I am trying to use, as I haven't coded it myself. It is deployed on the same JBoss-4.2.0.GA. The problem may be related to Spring jars, I am not sure. Kindly direct me if this is not the right forum to post this problem.

My code requests the service for some data. On the web service console, I get a classdefnotfound exception.I dont have the full stack trace right now. I will post it as soon as possible.

Thanks,
Usman
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5843
    
    7

It has been years since I worked with Spring and probably all of the stuff I remember is no longer valid. So let's look at this purely from a JBoss AS perspective. You will have to figure out how to convince MyEclipseForSpring to generate what is required.

I assume you have a WAR file. Please post the contents of the WAR file by running "jar -tf path/to/xxx.war" where path/to/xxx.war is the full or relative path to your war file.

Also post the full exception stack trace. Make sure you post the first exception stack trace if there are multiples. Alternately you can attach the root.log and server.log files.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Jboss-common-client.jar conflict