File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Mac OS and the fly likes Cannot update java on mac 10.4.11. bad address? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Engineering » Mac OS
Bookmark "Cannot update java on mac 10.4.11. bad address?" Watch "Cannot update java on mac 10.4.11. bad address?" New topic
Author

Cannot update java on mac 10.4.11. bad address?

John Broadway
Greenhorn

Joined: Aug 06, 2011
Posts: 1
My apologies for what will be my obvious ignorance. I am only a very new coder and have almost no experience with java itself.

In fact, my problem at the moment is trying to id and fix what seems to be a bad address when I try to use Release 9 to update J2SE 1.4.2 and J2SE 5.0. on a PPC G5 running 10.4.11. J2SE 1.4.2 and J2SE 5.0 show up in Java Prefs. When I use terminal java -version, it returns:

Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_05-83)
Java HotSpot(TM) Client VM (build 1.5.0_05-48, mixed mode, sharing)

So I would think that the Release 9 installer would execute. But when I launch the installer pkg, I get the message to run Software Update and all previous updates for java. Since I am running the last version of Tiger, I tried to install all previous releases of Java updates, from Release 6 - 8, but I get the same message to use Software Update and install previous Java versions.

I am going through this because a jar that tried to launch would fail and thus an app dependent on the jar executing would not launch.

In looking at one set of log info, a "bad address" message appeared. Below is the top line summary. I have the entire thread, but I haven't included it here because it is so long. Glad to do so if it would help someone steer me to the solution.

# This JavaNativeCrash log describes the Java state at a Native Crash in a Java application.
# The corresponding native state can be found in the crash log generated by CrashReporter.

# If this error is reproducible, please report it with the following information:
# 1. Provide the steps to reproduce, a test case, and any relevant information
# 2. This JavaNativeCrash_pid<num>.crash.log (Java state)
# 3. The corresponding <name>.crash.log (native state; generated by CrashReporter)
# File report at: http://bugreport.apple.com/

# An unexpected Java error has been detected by HotSpot Virtual Machine:
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_05-48 mixed mode, sharing)
#
# Internal Error (/SourceCache/HotSpot15/HotSpot15-48/src/os_cpu/macosx_ppc/vm/os_macosx_ppc.cpp, line 358), pid=4086, tid=25184768
#
# Error: java object has a bad address

--------------- T H R E A D ---------------


Many thanks in advance.

jmhseb
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Cannot update java on mac 10.4.11. bad address?