File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Build error. Compiler Adapter 'javac1.6' can't be found

 
Santhosh ayiappan
Ranch Hand
Posts: 80
Eclipse IDE Java Oracle
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The build file is successfully being run if the compiler="${JAVAC.COMPILER}"(javac1.5). But it fails if we use javac1.6.

This is the entry in build.xml file


The prop file entries are
DISTRIB.JAVAC.COMPILER=javac1.6 has issue -- javac1.5 it is working
DISTRIB.JAVAC.SOURCE=1.6
DISTRIB.JAVAC.TARGET=1.6

I have JDK .16 installed and ant 1.7 installed on my machine.

Any help would be greatly appreciated.
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are you using JDK 6 to run Ant? What is JAVA_HOME set to?

Which exact version of Ant? You mentioned 1.7, but is it really 1.7.1? (I'm looking at the 1.7.1 docs, which say that javac1.6 is valid; I don't know if it is valid in 1.7. Also, from reading the docs it appears that using javac1.6 is the same as using javac1.5, they are both aliases for "modern" which means to use the standard JDK compiler.)
 
Santhosh ayiappan
Ranch Hand
Posts: 80
Eclipse IDE Java Oracle
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
ANT version is 1.7 and the Java home is set to set JAVA_HOME=C:\Program Files\Java\jdk1.6.0_18.

Let me try to use Ant 1.7.1 and try to execute the ant script.

Regards
Santhosh
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic