wood burning stoves 2.0*
The moose likes EJB and other Java EE Technologies and the fly likes websphere6.1 and EJB3.0 in RSA7.5 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "websphere6.1 and EJB3.0 in RSA7.5" Watch "websphere6.1 and EJB3.0 in RSA7.5" New topic
Author

websphere6.1 and EJB3.0 in RSA7.5

shaz washere
Greenhorn

Joined: Aug 19, 2011
Posts: 2
Hello Everyone!

I'm kinda confused how to proceed in the recently installed RSA7.5 (over RSA7.0) on my system.

So previously i had setup my EJB project on RSA7.0 with EJB3.0 feature pack for WAS 6.1 along with JPA1.0. Now, we've had an upgrade to RSA7.5 which is said to have EJB3.0 and JPA1.0 INBUILT ! So, now when i try to import the RSA7.0 projects into RSA7.5, they are throwing lots of errors, mostly with annotations i had in the previous project files. so here are my questions-

1) Is there a proper procedure to migrate a RSA7.0 (WAS6.1-EJB3.0-JPA1.0) project setup to RSA7.5 (WAS6.1-EJB3.0-JPA1.0) ?
2) To experiment, I tried creating a new EJB project. in the wizard, when i select was6.1 as runtime it doesn't allow me to choose EJB3.0!! this list shows only till 2.1. did i miss something ?
3) would i need to remove jar files from the older project setup as these are now INBUILT in RSA7.5 ?
4) The final server on which the application EAR has to be deployed is a WAS6.1, so can i do all my development in WAS7.0 (using this removes the errors) and then deploy on WAS6.1 ? would that work without any problem ??

Any help is appreciated. Thanks!


[Thumbnail for EJB_Project_wizard.png]

 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: websphere6.1 and EJB3.0 in RSA7.5
 
Similar Threads
SCBCD5 exam query
Problem in Deployment of ejb3.0 on oc4j10g
Problem in Deployment of ejb3.0 on oc4j10g
XSLT transformations with JDK1.5 and Tomcat 5.5
EJB 3.0 + JPA, Comparation of mock test?