File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JDBC and the fly likes Caused by: java.lang.UnsatisfiedLinkError + Linux Server + 64 bit Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Databases » JDBC
Bookmark "Caused by: java.lang.UnsatisfiedLinkError + Linux Server + 64 bit" Watch "Caused by: java.lang.UnsatisfiedLinkError + Linux Server + 64 bit" New topic
Author

Caused by: java.lang.UnsatisfiedLinkError + Linux Server + 64 bit

Naresh Kavala
Greenhorn

Joined: Jun 07, 2008
Posts: 23
Hi Ranchers,

I am using third party jars to interact with an external agen called OMW from my web application. I am using all 64 bi version softares(jdk, eclipse, OS). Its working fine in local environment. But when I deploy the application in Linux server, I am getting following exception.
Exception ->
Caused by: java.lang.UnsatisfiedLinkError: no jopcagtbase in java.library.path
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1734)
at java.lang.Runtime.loadLibrary0(Runtime.java:823)
at java.lang.System.loadLibrary(System.java:1028)
at com.hp.openview.ib.api.jopc.JOpcAgentMessage.<clinit>(Unknown Source)

I know this error is because my application is not able to access native libraries and I have set required bin path in LD_LIBRARY_PATH variable. But the still the problem persists.
I am using , JDK 1.6.0_18
Jboss - 4.2.3
Linux 64 bit OS.
Do I need to set CLASSPATH variables separately. Could anybody please suggest, is there any special considerations need to take in linux environment.

Warm Regards,
Naresh.
Ernest Friedman-Hill
author and iconoclast
Marshal

Joined: Jul 08, 2003
Posts: 24187
    
  34

Are you sure you have a 64-bit Linux version of this native library, and not a 32-bit Linux version, or some other version altogether? The native library is specific to the platform.

The correct way to tell Java about native libraries is with the java.library.path system property -- i.e.,



although setting LD_LIBRARY_PATH will often work.


[Jess in Action][AskingGoodQuestions]
 
 
subject: Caused by: java.lang.UnsatisfiedLinkError + Linux Server + 64 bit