This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes Web Services and the fly likes Error when deploying Web service to Axis runtime Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "Error when deploying Web service to Axis runtime" Watch "Error when deploying Web service to Axis runtime" New topic
Author

Error when deploying Web service to Axis runtime

Gajanan Gawhale
Greenhorn

Joined: Jun 26, 2010
Posts: 3
Hi All,

I am using Application Server Toolkit IDE and server is Web Sphere Application Server 6.1. I want to build a new web service

so that third party clients can call it.
I following following steps:
1. I wrote a xsd file under a web project in /WEB-INF/wsdl folder and generated a wsdl using the IDE.
2. I made some necessary changes in wsdl file.
3. Now I want to generate the web service code and want to deploy it on WAS server using Apache Axis.
4. I first set the Server as Web sphere v6.1 Server and Web Service runtime as Apache Axis in preference->Web Service->Server and Runtime.
5. I started the app server.
6. I selected the wsdl file and using wizard to create web service. Selected the web service type as Top down java bean web service.
- selected the wsdl file in service definition.
- Selected the web service bar upto Start Service level.
- Selected the publish the service check box.
- Click on finish button.
7. The service code got generated but while deploying the service to app server i received a error message window with

followin error -

IWAB0489E Error when deploying Web service to Axis runtime
axis-admin failed with {http://schemas.xmlsoap.org/soap/envelope/}Server.userException

javax.net.ssl.SSLHandshakeException: com.ibm.jsse2.util.h: No trusted certificate found


I am not able understand why is this error. Why certificate is needed to deploy the service? And what do i need to do to solve this problem?

I am very scared of certificate issues because i don't understand them at all and this is the first time i am writing a web service so please help me with this.

Thanks a lot


[Thumbnail for preferences.png]

[Thumbnail for error.png]

Vijayendra Bhati
Greenhorn

Joined: Jul 26, 2006
Posts: 3
I am also facing same issue.Please let me know how you resolved this.
Bharathula Venkata
Greenhorn

Joined: Jun 28, 2010
Posts: 5
I too get the same error, By chance did you get any solution??
J Dirksen
Author
Greenhorn

Joined: Sep 04, 2012
Posts: 13
Might this help:

http://www-01.ibm.com/support/docview.wss?uid=swg21279327

Seems to be a somewhat related problem, where a certificate is missing from the client truststore.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Error when deploying Web service to Axis runtime
 
Similar Threads
How to change the name of the binding element in wsdl file ?
Axis Web Service Client : NullPointerException
how to consume a webservice using axis2
How to change the name of the binding element in wsdl file ?
Issue while deploying web service jwstutorial example CLI171