• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JSF2/Richfaces4 not loading contents of .ecss files

 
Tommy Gunner
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm upgrading to Richfaces 4 and the Sun implementation of JSF2 (2.0.6) from Richfaces 3.3 and JSF 1.2.

My css files are under 'WebContent/resources/css'.

When pages get rendered, all .css files get loaded correctly.

For some reason the content of my .ecss files do not get loaded, any ideas why this is?

Do I need some extra settings in my web.xml?




broken.ecss:



Looking at firebug, the styles in broken.ecss are not been found.

One thing I did notice is the path to the files. My css files have the JSF2 resources path while ecss files have the Richfaces resources path. Could this be the issue (Seen as I have all my files under the default JSF2 resources location)?



Also, the following is shown in logs:




UPDATE

Ok, the 302 was due to a redirect for errors I had in my web.xml. Now I can see the true cause of the problem:



Do I need to include some sort of CSSOMParse jar in my app also?

Thanks
 
Tommy Gunner
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ok.....I download and added the cssParser-0.9.5.jar to my webApp and it fixed the problem!

http://sourceforge.net/projects/cssparser/files/cssparser/0.9.5/cssparser-0.9.5.jar/download

I origionally had the folowing jar which I thought was all that was neeed for the Richfaces4 upgrade: sac-1.0.0.1.jar.

Theres seems to be no mention of adding the cssParser jar to projects when upgrading to Richfaces 4, is there a reason for this or am I missing something here?

I'm getting more frustrated by the day with Richfaces limited examples, documentation and more importantly a large enough community to answer questions like these

Thanks
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic