aspose file tools*
The moose likes Portals and Portlets and the fly likes Timeout waiting for Oracle WebLogic Server v10.3 at localhost to start Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Portals and Portlets
Bookmark "Timeout waiting for Oracle WebLogic Server v10.3 at localhost to start" Watch "Timeout waiting for Oracle WebLogic Server v10.3 at localhost to start" New topic
Author

Timeout waiting for Oracle WebLogic Server v10.3 at localhost to start

Gopikrishna Gopal
Greenhorn

Joined: Sep 08, 2011
Posts: 26
I am trying to run .portal file using "Run on server" option in Workshop for weblogic.
After doing this, its trying to start the server Oracle weblogic server v10.3 at localhost and then publish my module.
Server view status shows as "State" as "Starting" and "Status" as "Synchronizing". When status reaches 82% it gets stopped there for a long time, and when 83% comes up, I can see the "State" as "Stopped" and "Status" as "Republish". And then an error window with title as "Problem Occured" and contents saying, Starting server- Oracle weblogic server v10.3 at localhost (Time of error: ...) Details >> Timeout waiting for Oracle WebLogic Server v10.3 at localhost to start. Server did not start after 480s.

But the console tab (when I give the startup & Deployment option as "Launch Weblogic server in eclipse console) shows,
<Sep 8, 2011 6:15:03 PM IST> <Notice> <WebLogicServer> <BEA-000365> <Server sta
e changed to STARTING> (final step alone I pasted)
Before this I can see, WLS Start mode = Development, setting Classpath ,
<Sep 8, 2011 5:56:36 PM IST> <Notice> <Log Management> <BEA-170019> <The server
log file C:\bea\user_projects\domains\myPortalDomain\servers\AdminServer\logs\Ad
minServer.log is opened. All server side log events will be written to this file
.>

When I checked Adminserver file its having,
<AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1315487671986> <BEA-160151> <Registered library Extension-Name: wlp-groupspace-app-lib, Specification-Version: 10.3, Implementation-Version: 10.3.0.1 (EAR).>
And many more similar entries...

Also there is Adminserver.logxxx file which is having,
####<Sep 8, 2011 5:33:58 PM IST> <Warning> <JDBC> <AdminServer> <[ACTIVE] ExecuteThread: '2' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1315483438048> <BEA-001129> <Received exception while creating connection for pool "portalDataSourceNeverXA": SQL-server rejected establishment of SQL-connection. Pointbase Server may not be running on localhost at port 9093.>
####<Sep 8, 2011 5:33:58 PM IST> <Info> <JDBC> <CINTNCHEOLY0GX7> <AdminServer> <[ACTIVE] ExecuteThread: '2' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1315483438267> <BEA-001156> <Stack trace associated with message 001129 follows:

java.sql.SQLException: SQL-server rejected establishment of SQL-connection. Pointbase Server may not be running on localhost at port 9093.
at com.pointbase.dbexcp.dbexcpException.getSQLException(Unknown Source)
at com.pointbase.net.netJDBCConnection.a(Unknown Source)
at com.pointbase.net.netJDBCConnection.<init>(Unknown Source)
at com.pointbase.net.netJDBCDriver.getConnection(DashoA10*..:170)
at com.pointbase.net.netJDBCDriver.connect(DashoA10*..:94)
at com.pointbase.jdbc.jdbcUniversalDriver.getConnection(Unknown Source)
at com.pointbase.jdbc.jdbcUniversalDriver.connect(Unknown Source)
at weblogic.jdbc.common.internal.ConnectionEnvFactory.makeConnection(ConnectionEnvFactory.java:316)
at weblogic.jdbc.common.internal.ConnectionEnvFactory.createResource(ConnectionEnvFactory.java:217)
at weblogic.common.resourcepool.ResourcePoolImpl.makeResources(ResourcePoolImpl.java:1109)
at weblogic.common.resourcepool.ResourcePoolImpl$ResourcePoolMaintanenceTask.timerExpired(ResourcePoolImpl.java:2282)
at weblogic.timers.internal.TimerImpl.run(TimerImpl.java:273)
at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:516)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:173)

And many more entries like the above...

I even tried startup & Deployment option as "Start weblogic server in Expressmode" and still same error I am getting and this time instead of in eclipse console, I can see command prompt and here also showing "Server state changed to STARTING"

FYI, I created domain with runtime JRocket 1.6.0_05.

I even tried to clean build the portal project and publish using clean option. Still same problem coming

FYI, my system is having 1 GB RAM only and bit slow. Could this be a problem or something else? Please suggest.
Thanks in advance.

Maneesh Godbole
Saloon Keeper

Joined: Jul 26, 2007
Posts: 10384
    
    8

Welcome to the Ranch.
Did you notice this?
java.sql.SQLException: SQL-server rejected establishment of SQL-connection. Pointbase Server may not be running on localhost at port 9093.


[How to ask questions] [Donate a pint, save a life!] [Onff-turn it on!]
Gopikrishna Gopal
Greenhorn

Joined: Sep 08, 2011
Posts: 26
Maneesh Godbole wrote:Welcome to the Ranch.
Did you notice this?
java.sql.SQLException: SQL-server rejected establishment of SQL-connection. Pointbase Server may not be running on localhost at port 9093.




Hi,

I went into portal domain root folder, then in cmd prompt, when I do "startWebLogic" , there is no progress at all. I mean nothing is displayed.

But when I checked pointbase file in the portal domain root folder, its showing,
Server started, listening on port 9092, display level: 3 ...


Then in cmd prompt, only when I type "quit" , its showing progress as follows,

quit
.
.
JAVA Memory arguments: -Xms128m -Xmx256m
.
WLS Start Mode=Development

Setting Classpaths etc......

Then the same old error is coming again that I posted in my previous post.

Now, when I check the Pointbase file, its showing,

Server started, listening on port 9092, display level: 3 ...


PointBase Server Stopped.

And pointbaseShutdown is showing,

*****************************************************************
-driver com.pointbase.jdbc.jdbcUniversalDriver
-url jdbc:pointbase:server://localhost:9092/demo
-script <none>
-user PBSYSADMIN
-password PBSYSADMIN
-autocommit true
-prompt2 true
-spoolfile <none>
-silent false
*****************************************************************
SQL-server rejected establishment of SQL-connection. Pointbase Server may not be running on localhost at port 9092.

Please suggest, Thanks !
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Timeout waiting for Oracle WebLogic Server v10.3 at localhost to start