This week's book giveaway is in the Design forum.
We're giving away four copies of Design for the Mind and have Victor S. Yocco on-line!
See this thread for details.
Win a copy of Design for the Mind this week in the Design forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Hans53 Emulator will not start

 
Hans Petterson
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All
I have just installed Android SDK and Eclipse with the Android plug-in
Then I walked Hello Android tutorial on http://developer.android.com/resources/tutorials/hello-world.html
The installation was OK, without any error or warnings, but when I tryed to run the Hello Android app with Eclipse I got the following in the Eclipse console window and the emulator refuses to start
[2011-09-12 17:49:00 - HelloAnderoid] ------------------------------
[2011-09-12 17:49:00 - HelloAnderoid] Android Launch!
[2011-09-12 17:49:00 - HelloAnderoid] adb is running normally.
[2011-09-12 17:49:00 - HelloAnderoid] Performing se.example.helloanderiod.HelloAnderoidActivity activity launch
[2011-09-12 17:49:00 - HelloAnderoid] Automatic Target Mode: launching new emulator with compatible AVD 'kl'
[2011-09-12 17:49:00 - HelloAnderoid] Launching a new emulator with Virtual Device 'kl'
[2011-09-12 17:49:04 - Emulator] invalid command-line parameter: Files.
[2011-09-12 17:49:04 - Emulator] Hint: use '@foo' to launch a virtual device named 'foo'.
[2011-09-12 17:49:04 - Emulator] please use -help for more information

I have installed the apk file on my android phone and there it works OK

My environment loks like this
JDK7 : C:\Program Files\Java\jdk1.7.0
C:\Program Files\Java\jre7
Android SDK: C:\Program Files (x86)\Android\android-sdk
Eclipse: C:\Users\Hans\Documents\Anderoid_development_downloads\eclipse

I have also tried to start it with the Android AVD manager with same result
invalid command-line parameter: Files.
Hint: use '@foo' to launch a virtual device named 'foo'.
please use -help for more information

Is there any one who can say way and what to do about it
With regards
HansP
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What is Hans53? Did you create your own AVD? If so:

a) have you tried using one of the pre-defined AVDs instead?
b) please post the configuration information for the AVD you created
 
Hans Petterson
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hans53: I do not know, it was some default text appearing in the subject field
Yes I have created my own AVD
a: No I have not tried that, as you could see from my first post the SDK and Eclipse where installed the other evening and the tutorial run just after
I have looked in all places I can think of but could not find a solution for the problem, and I have not seen anything about any predefined AVD's
Where can I find them, and how do I use them
b:The configuration information, this is the contents of the fonfig.ini for the AVD I’ve created
Thank you for your responce
HansP
 
Vishal Trivedi
Ranch Hand
Posts: 57
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hans Petterson wrote:Hans53: I do not know, it was some default text appearing in the subject field
Yes I have created my own AVD
a: No I have not tried that, as you could see from my first post the SDK and Eclipse where installed the other evening and the tutorial run just after
I have looked in all places I can think of but could not find a solution for the problem, and I have not seen anything about any predefined AVD's
Where can I find them, and how do I use them
b:The configuration information, this is the contents of the fonfig.ini for the AVD I’ve created
Thank you for your responce
HansP


what version of Android did you download...
because i had the same problem and it worked when i changed the android sdk path..

C:\PROGRA~2\Android\android-sdk

this shld do the trick
else try this

C:\PROGRA~1\Android\android-sdk

change them in eclipse
 
Hans Petterson
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Vishal Trivedi wrote:what version of Android did you download...because i had the same problem nd it worked when i changed the android sdk path..
C:\PROGRA~2\Android\android-sdk
this shld do the trick
else try this
C:\PROGRA~1\Android\android-sdk
change them in eclipse


Thank you for your responce.
Could you please give a more detailed explination of what I should do
The path to my Sdk C:\Program Files (x86)\Android\android-sdk
Shall I uninstal the SDK and install it somewhere else
Or is it just to change a path i Eclipse, if so where /how do I do that
I tryed to change the path in Eclips Window/Preferences Android but the the Project didnot build at all
"C:\PROGRA~2\Android\android-sdk
this shld do the trick
else try this
C:\PROGRA~1\Android\android-sdk"
I do not know what you mean with this !!
HansP
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I recommend moving the SDK out of Program Files all together! Spaces in paths can cause all kinds of problems. I have my SDK installed at d:\opt\android\android-sdk-windows. And I have Eclipse at d:\opt\android\eclipse and the workspace at d:\opt\android\workspace.

As hinted at in Vishal's post, the short name for Program Files varies; it depends on what other files and folders you have that start with "Progra". So you can either try figuring out what the digit at the end of the directory name should be (is is Progra~1, Progra~2, or Porga~3 or...) or you can avoid paths with spaces in the completely.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic