aspose file tools*
The moose likes Tomcat and the fly likes Tomcat 7.0.21 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Tomcat 7.0.21" Watch "Tomcat 7.0.21" New topic
Author

Tomcat 7.0.21

Philip Coetzee
Greenhorn

Joined: Sep 15, 2011
Posts: 2
To whom it may concern:
I have been running and using Tomcat 4.1 up to now with out issues. Now there were other things which forced me to download Tomcat 7.0.21.

The installation did not give any problems and the server started up with out errors as well.

The only problem is when i enter the URL http://localhost:8080, i get the "Page not found" (page 404) web page displayed. I have tried to see very where but i just can not seem to find the problem.

Also each time I try the above URL, the following entry is made in the localhost_access_log file.

127.0.0.1 - - [15/Sep/2011:12:57:33 +0200] "GET / HTTP/1.1" 404 -

So something must be talking to tomcat, but why is the default Tomcat pages not shown?

PLease can someone urgently help?

My Operating system is Windows XP SP3.
I have the latest jdk installed as well.


Thanks you.

Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 16303
    
  21

Most likely because Tomcat has been moving away from the idea that it should have any webapps pre-installed in the server. Starting somewhere around Tomcat 5, the Tomcat admin and management webapps became separate downloads.


Customer surveys are for companies who didn't pay proper attention to begin with.
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 42910
    
  68
Tomcat 7 still ships with the ROOT web app - the URL "/" should work out of the box. Are there any error messages in one of the log files?
Philip Coetzee
Greenhorn

Joined: Sep 15, 2011
Posts: 2
Hi,

No errors were in the log file.

Perhaps i have not given enough info previousely.

I installed it on a separate PC and the full installation works 100%. But on my pc, the Tomcat service starts up ok, no errors in the log and not errors during statup.

Also When I check the 3 ports Tomcat uses using netstat I can not see any other ports trying to listen to those 3 ports. The interresting thing is, when i STOP the Tomcat service, then try netstat, there are nothing listening to ports 8080 and the other 2.

When i start Tomcat service, only Tomcat is listening to the three ports.
Yet, when I try the localhost:8080, i get page not found.

When i STOP Tomcat and try localhost:8080, I get a connection error and NOT the no page.

It seems that Tomcat is returning the NO page to display.

ANy ideas?

 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Tomcat 7.0.21