aspose file tools*
The moose likes JBoss/WildFly and the fly likes Eclipse/JBoss stuck Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Eclipse/JBoss stuck" Watch "Eclipse/JBoss stuck" New topic
Author

Eclipse/JBoss stuck

rahull agarwal
Ranch Hand

Joined: Dec 20, 2010
Posts: 31
Hi,

I use Jboss and Eclipse.

Whenever I start my web application, it seems to get stuck at following

09:28:50,868 ERROR [STDERR] 15295 [main] INFO org.jboss.resteasy.plugins.providers - Adding built in provider org.jboss.resteasy.plugins.providers.YamlProvider

It stays at this line for about couple of minutes.

Is there something missing? I am facing this behavior for about 2 years now.

Thanks in advance.
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5842
    
    7

Try taking some JVM thread dumps during that time and see what the active threads are doing. I suspect that whatever code put out this message is then going out to the network getting information.


JBoss In Action
rahull agarwal
Ranch Hand

Joined: Dec 20, 2010
Posts: 31
It was a networking issue.

Resolved.

Thanks.
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5842
    
    7

Is there anything specific you did to resolve the issue? If so, please post what you did for the benefit of others who will run across this post when they have the same problem.
rahull agarwal
Ranch Hand

Joined: Dec 20, 2010
Posts: 31
The fix was beyond my understanding. However, I will try my best to explain.

I called networking person. He saw that my machine was incorrectly configured to talk to the network. It was trying 3 different connections (1 regular and 2 vmware).

He removed vmware connection settings from my network connections.

Life has been happy ever since.
 
wood burning stoves
 
subject: Eclipse/JBoss stuck