aspose file tools*
The moose likes JSF and the fly likes Richfaces listShuttle inside a modalPanel missing data Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » JSF
Bookmark "Richfaces listShuttle inside a modalPanel missing data" Watch "Richfaces listShuttle inside a modalPanel missing data" New topic
Author

Richfaces listShuttle inside a modalPanel missing data

J Miller
Ranch Hand

Joined: Oct 21, 2010
Posts: 67
I’m having a problem combining the listShuttle and modalPanel components of RichFaces. I’m currently working on a page where you would click an icon that pops up a rich:modalPanel. Inside that modal window would be a tabPanel, and inside one of the tabs would be a listShuttle.

When you open the modal panel, the window pops up, and the listShuttle renders, but both lists are empty. I had this on the page, not in a modal, and the shuttle was working without problem. I took that code, and wrapped it inside a modalPanel, and now it’s not working. I've verified that the lists that the shuttle is bound to DO have data in them, and the getter methods for those lists are being called.

Here’s what my code looks like:




As always, any help would be appreciated!
J Miller
Ranch Hand

Joined: Oct 21, 2010
Posts: 67
Never mind. As it turns out when I moved the code into the modal, I also stopped calling the method that loaded the list objects. Dumb mistake
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Richfaces listShuttle inside a modalPanel missing data