aspose file tools*
The moose likes IDEs, Version Control and other tools and the fly likes Eclipse Content Assist is not working while creating a project from an ant build file Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Eclipse Content Assist is not working while creating a project from an ant build file" Watch "Eclipse Content Assist is not working while creating a project from an ant build file" New topic
Author

Eclipse Content Assist is not working while creating a project from an ant build file

Kuts Aryan
Greenhorn

Joined: Jun 27, 2009
Posts: 14
Hi all
I want to create a j2EE projects from an ant build file.Hence I created a project in eclipse from File->New->Project and written the ant build file.Based on the build file, I created the required folder structure. But the problem is while writting any java code or servlet code,I am not getting any content assist facilities also eclipse IDE not showing me any compilation error as it is using my custom ant build.
It will be helpful if you suggest me how to configure eclipse in this scenario so that I can get the content assist facilities along with if I make any changes in my code,eclipse will automatically run my ant script to validate the changes.

Thanks
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5823
    
    7

What kind of project did you create? A general project? Or a Java project? With a general project, there is no Java builder or source path, so you will get errors about there not being a build path. Also, when you are editing you java source code, which editor are you using? The Text Editor will not provide autocompletion, you must use the Java Editor.

If this doesn't help, a fuller description exactly how you created the project and exactly how you created the Java source files would help.


JBoss In Action
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Eclipse Content Assist is not working while creating a project from an ant build file