• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

SCWCD 5 & Tomcat.

 
Sean Keane
Ranch Hand
Posts: 582
Chrome Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The FAQ page says that you should use version 5.5.28 of Tomcat when studying for the SCWCD 5. So I'm guessing the same applies to OCPJWCD.

Taking a look at the Tomcat page on Wikipedia here it says the latest 5.x release is 5.5.34.

Would there be any reason not to use the latest 5.x version for OCPJWCD i.e. use 5.5.34 instead of 5.5.28?

Taking a look at the Tomcat page it has the following:
Apache Tomcat 5.5.x supports the same Servlet and JSP Specification versions as Apache Tomcat 5.0.x.
There are significant changes in many areas under the hood, resulting in improved performance, stability, and total
cost of ownership. Please refer to the Apache Tomcat 5.5 Changelog for details.

So, from that I gather that there is no change in the specification in any of the 5.x versions. So it seems it would make sense to use the latest 5.x.?
 
Niiraj Patel
Ranch Hand
Posts: 47
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
@ Sean,

You can use Tomcat's latest version 5.x.

There would no such impact on your exam OCPJWCD 5.0.

Apache Tomcat version 5.5.x implements and follows servlet 2.4 and JSP 2.0.

http://tomcat.apache.org/whichversion.html





 
Sean Keane
Ranch Hand
Posts: 582
Chrome Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Niiraj Patel wrote:You can use Tomcat's latest version 5.x.

Cheers for the reply. This is the conclusion I came to myself. It would be worth updating the FAQ to state that the latest 5.X version can be used so as to avoid any confusion.
Niiraj Patel wrote:Apache Tomcat version 5.5.x implements and follows servlet 2.4 and JSP 2.0.

http://tomcat.apache.org/whichversion.html

That is the page I linked to in my post above - it doesn't actually say what spec that Tomcat 5.X implements. It mentions what every version of Tomcat other than 5.X implements - which I found strange.

If you look at the documentation for 5.5 located here http://tomcat.apache.org/tomcat-5.5-doc/index.html, it outlines what spec it implements.
 
Ankit Garg
Sheriff
Posts: 9521
22
Android Google Web Toolkit Hibernate IntelliJ IDE Java Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The FAQ has been updated, remember any ranch member can change the FAQ if they find something is outdated/wrong...
 
Sean Keane
Ranch Hand
Posts: 582
Chrome Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ankit Garg wrote:The FAQ has been updated, remember any ranch member can change the FAQ if they find something is outdated/wrong...


Ah, I didn't realise that a mere Ranch Hand like me could update it - I'll know better for the future . Thanks for updating.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic