aspose file tools*
The moose likes Struts and the fly likes Struts2 Spring AOP required jars Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Struts2 Spring AOP required jars" Watch "Struts2 Spring AOP required jars" New topic
Author

Struts2 Spring AOP required jars

madhun reddy
Greenhorn

Joined: Sep 29, 2011
Posts: 4
Hi,

I am trying to implement project using Struts2-Spring-AOP, but I am getting following strange error.

java.lang.RuntimeException: Invalid action class configuration that references an unknown class named [itemservice]
org.apache.struts2.convention.ConventionsServiceImpl.determineResultPath(ConventionsServiceImpl.java:99)
org.apache.struts2.convention.ConventionUnknownHandler.determinePath(ConventionUnknownHandler.java:379)
org.apache.struts2.convention.ConventionUnknownHandler.handleUnknownResult(ConventionUnknownHandler.java:268)

Following are the library files I am using, please let me know if I need to remove/add any jars.

antlr-runtime-3.0.jar
aopalliance.jar
aspectjrt.jar
aspectjweaver.jar
cglib-nodep-2.1_3.jar
commons-beanutils.jar
commons-collections-2.1.1.jar
commons-dbcp.jar
commons-fileupload-1.2.1.jar
commons-io-1.3.2.jar
commons-logging-1.1.jar
commons-pool.jar
freemarker-2.3.13.jar
jstl.jar
junit-3.8.1.jar
mysql-connector-java-5.1.6-bin.jar
ognl-2.6.11.jar
org.springframework.asm-3.0.0.M3.jar
org.springframework.beans-3.0.0.M3.jar
org.springframework.context-3.0.0.M3.jar
org.springframework.core-3.0.0.M3.jar
org.springframework.expression-3.0.0.M3.j

org.springframework.web-3.0.0.M3.jar
org.springframework.web.servlet-3.0.0.M3.

spring-aop.jar
spring-jdbc.jar
spring-ldap-1.2.1.jar
spring-orm.jar
spring-security-core-2.0.3.jar
spring-tx.jar
struts2-convention-plugin-2.1.6.jar
struts2-core-2.1.6.jar
struts2-spring-plugin-2.1.6.jar
xwork-2.1.2.jar

thanks
Madhu
debraj mallick
Ranch Hand

Joined: Mar 08, 2011
Posts: 188

hi there,

please put some more details, like struts.xml etc, so that we could help you.
what is itemservice?
madhun reddy
Greenhorn

Joined: Sep 29, 2011
Posts: 4
We were able to solve the issue, the problem was mainly due to error in validation xml file for the a action class.

But I have a general doubt on what all jars need to be used for implementing projects in using following technologies:
1. Strut2
2. Tiles
3. Spring
4. Spring-AOP
5. LDAP
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Struts2 Spring AOP required jars