This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes Portals and Portlets and the fly likes Authentication for user weblogic denied Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » Portals and Portlets
Bookmark "Authentication for user weblogic denied " Watch "Authentication for user weblogic denied " New topic
Author

Authentication for user weblogic denied

Gopikrishna Gopal
Greenhorn

Joined: Sep 08, 2011
Posts: 26
When I try to start WebLogic using the command "startWebLogic.cmd" from my domain home, I am getting the below error, that I pasted from AdminServer.log file,

java.sql.SQLException: [Security:090735]The DBMS connection was not usable
at weblogic.security.providers.authentication.DBMSSQLAuthenticatorDelegateImpl.getManageableConnection(DBMSSQLAuthenticatorDelegateImpl.java:923)
at weblogic.security.providers.authentication.DBMSSQLAuthenticatorDelegateImpl.validateConfiguration(DBMSSQLAuthenticatorDelegateImpl.java:153)
at weblogic.security.providers.authentication.DBMSSQLAuthenticatorDelegateImpl.<init>(DBMSSQLAuthenticatorDelegateImpl.java:78)
at weblogic.security.providers.authentication.DBMSAuthenticatorDelegateImpl.getInstance(DBMSAuthenticatorDelegateImpl.java:459)
at weblogic.security.providers.authentication.DBMSSQLAuthenticationProviderImpl.initialize(DBMSSQLAuthenticationProviderImpl.java:56)
at com.bea.common.security.internal.legacy.service.SecurityProviderImpl.init(SecurityProviderImpl.java:65)
at com.bea.common.engine.internal.ServiceEngineImpl.findOrStartService(ServiceEngineImpl.java:363)
at com.bea.common.engine.internal.ServiceEngineImpl.findOrStartService(ServiceEngineImpl.java:315)
at com.bea.common.engine.internal.ServiceEngineImpl.lookupService(ServiceEngineImpl.java:257)
at com.bea.common.engine.internal.ServicesImpl.getService(ServicesImpl.java:72)
at weblogic.security.service.internal.WLSIdentityServiceImpl.initialize(Unknown Source)
at weblogic.security.service.CSSWLSDelegateImpl.initializeServiceEngine(Unknown Source)
at weblogic.security.service.CSSWLSDelegateImpl.initialize(Unknown Source)
at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.InitializeServiceEngine(Unknown Source)
at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.initializeRealm(Unknown Source)
at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.loadRealm(Unknown Source)
at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.initializeRealms(Unknown Source)
at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.initialize(Unknown Source)
at weblogic.security.service.SecurityServiceManager.initialize(Unknown Source)
at weblogic.security.SecurityService.start(SecurityService.java:141)
at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:173)


####<Sep 30, 2011 7:07:37 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389857978> <BEA-090075> <The SAMLIdentityAssertor provider has had its LDIF information loaded from: C:\bea\user_projects\domains\myPortalDomain\security\SAMLIdentityAssertorInit.ldift>
####<Sep 30, 2011 7:07:38 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389858245> <BEA-090851> <The SAMLIdentityAsserter provider is initialized.>
####<Sep 30, 2011 7:07:38 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389858920> <BEA-090516> <The CredentialMapper provider has preexisting LDAP data.>
####<Sep 30, 2011 7:07:39 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389859659> <BEA-090516> <The Authorizer provider has preexisting LDAP data.>
####<Sep 30, 2011 7:07:41 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389861370> <BEA-090075> <The SAMLCredentialMapper provider has had its LDIF information loaded from: C:\bea\user_projects\domains\myPortalDomain\security\SAMLCredentialMapperInit.ldift>
####<Sep 30, 2011 7:07:41 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389861480> <BEA-090851> <The SAMLCredentialMapperV2 provider is initialized.>
####<Sep 30, 2011 7:07:41 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389861559> <BEA-090516> <The CredentialMapper provider has preexisting LDAP data.>
####<Sep 30, 2011 7:07:41 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389861669> <BEA-090516> <The RoleMapper provider has preexisting LDAP data.>
####<Sep 30, 2011 7:07:42 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389862203> <BEA-090093> <No pre-WLS 8.1 Keystore providers are configured for server AdminServer for security realm myrealm.>
####<Sep 30, 2011 7:07:42 PM IST> <Notice> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389862203> <BEA-090082> <Security initializing using security realm myrealm.>
####<Sep 30, 2011 7:07:58 PM IST> <Error> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389878205> <BEA-000000> <[Security:090735]The DBMS connection was not usable>
####<Sep 30, 2011 7:07:58 PM IST> <Critical> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389878283> <BEA-090403> <Authentication for user weblogic denied>
####<Sep 30, 2011 7:07:58 PM IST> <Critical> <WebLogicServer> <AdminServer> <Main Thread> <<WLS Kernel>> <1317389878299> <BEA-000386> <Server subsystem failed. Reason: weblogic.security.SecurityInitializationException: Authentication for user weblogic denied
weblogic.security.SecurityInitializationException: Authentication for user weblogic denied
at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.doBootAuthorization(Unknown Source)
at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.initialize(Unknown Source)
at weblogic.security.service.SecurityServiceManager.initialize(Unknown Source)
at weblogic.security.SecurityService.start(SecurityService.java:141)
at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:173)

How to resolve this please?

And another thing is, after PointBase server is started,

C:\bea\user_projects\domains\myPortalDomain>"C:\bea\JROCKI~1\bin\java" com.point
base.net.netServer /port:9092 /d:3 /pointbase.ini="C:\bea\wlserver_10.3\samples\
domains\wl_server\pointbase.ini"
Server started, listening on port 9092, display level: 3 ...

Its not recognising any command at this moment. How to proceed with the other commands that are followed after this ?

I even added GOTO :EOF, after Pointbase is called like below, but still its not proceeding after >

@rem Start PointBase
"%JAVA_HOME%\bin\java" com.pointbase.net.netServer /port:9092 /d:3 /pointbase.ini="%SAMPLES_HOME%\domains\wl_server\pointbase.ini"

GOTO :EOF

:EOF

Only its recognizing the command "quit" but that is stopping the Pointbase server.
Ove Lindström
Ranch Hand

Joined: Mar 10, 2008
Posts: 326

Basically, the stack trace tells you what is wrong.

The DS-file that you are (should be) using is declaring a user/password pair that is not matching what you have in the database.

It seems that you are declaring a datasource but the credentials are wrong.

See http://download.oracle.com/docs/cd/E13222_01/wls/docs90/jdbc_admin/jdbc_datasources.html for more info.
Gopikrishna Gopal
Greenhorn

Joined: Sep 08, 2011
Posts: 26
I am able to start weblogic from command prompt using "startWebLogic.cmd"
But from Oracle Workshop for Weblogic, under Servers tab , when I right click Oracle WebLogic Server v10.3 at localhost and click on Start, I am getting Server did not start. Timeout Waiting for Oracle Weblogic server to start within 480s or something like that after long time. But in console Tab, I can see admin server started as follows,

WebLogic Server 10.3 Fri Jul 25 16:30:05 EDT 2008 1137967 >
<Oct 4, 2011 8:17:55 PM IST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to STARTING>
<Oct 4, 2011 8:17:55 PM IST> <Info> <WorkManager> <BEA-002900> <Initializing self-tuning thread pool>
<Oct 4, 2011 8:17:57 PM IST> <Notice> <Log Management> <BEA-170019> <The server log file C:\bea\user_projects\domains\myPortalDomain1\servers\AdminServer\logs\AdminServer.log is opened. All server side log events will be written to this file.>
<Oct 4, 2011 8:19:53 PM IST> <Notice> <Security> <BEA-090082> <Security initializing using security realm myrealm.>
<Oct 4, 2011 8:21:21 PM IST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to STANDBY>
<Oct 4, 2011 8:21:21 PM IST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to STARTING>


But When I try to access console using, http://localhost:7001/console
I am getting, This program cannot display the webpage

I even tried replacing 2 occurences of "localhost" to "my ip address" in config.xml under domain\config path.

<sec:connection-url>jdbc:pointbase:server://<my-ip-address>:9092/demo</sec:connection-url>
<sec:connection-properties>user=PBSYSADMIN,databaseName=jdbc:pointbase:server://<my-ip-address>:9092/demo</sec:connection-properties>

Then in all the JDBC data source xml's in the path domain\config\jdbc, I replaced "localhost" to "my ip address"

<url>jdbc:pointbase:server://<my-ip-address>:9092/demo</url>

Then when I try accessing the page using, http://<my-ip-address>:7001/console,
still I am getting Page cannot be displayed.

Please help me on solving this problem as well as Timeout problem occuring on Oracle Workshop. FYI I am having Portal Perspective.
 
 
subject: Authentication for user weblogic denied
 
Similar Threads
Timeout waiting for Oracle WebLogic Server v10.3 at localhost to start
Change application state "Start Running" to "Active"
Failed to start JMS Server
Authentication for user weblogic denied
Publishing failing - Changing to Republish mode :( Please help !!