aspose file tools*
The moose likes Portals and Portlets and the fly likes Authentication for user weblogic denied Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Java » Portals and Portlets
Reply locked New topic
Author

Authentication for user weblogic denied

Gopikrishna Gopal
Greenhorn

Joined: Sep 08, 2011
Posts: 26
When I try to start WebLogic using the command "startWebLogic.cmd" from my domain home, I am getting the below error, that I pasted from AdminServer.log file.

But before pasting the error, let me tell something that I have to do in order to proceed further.


After "startWebLogic.cmd" is given, there is no progress at all, and I need to press "quit" for further action.
Since I couldn't see where exactly its stopping, I enabled "echo" in some of the .cmd's and this time I see the below (note: not pasted everything but I pasted the output just before it has stopped executing)

C:\bea\user_projects\domains\myPortalDomain>"C:\bea\JROCKI~1\bin\java" com.point
base.net.netServer /port:9092 /d:3 /pointbase.ini="C:\bea\wlserver_10.3\samples\
domains\wl_server\pointbase.ini"
Server started, listening on port 9092, display level: 3 ...
>

So its stopping at this point, and I have to enter "quit", but I guess that is stopping the pointbase server.

I even added GOTO :EOF in "startPointBase.cmd" after Pointbase is called like below, but still its not proceeding after > (greater than symbol)

@rem Start PointBase
"%JAVA_HOME%\bin\java" com.pointbase.net.netServer /port:9092 /d:3 /pointbase.ini="%SAMPLES_HOME%\domains\wl_server\pointbase.ini"

GOTO :EOF

:EOF

Now, coming back to the error that I am getting, its pasted below...

java.sql.SQLException: [Security:090735]The DBMS connection was not usable
at weblogic.security.providers.authentication.DBMSSQLAuthenticatorDelegateImpl.getManageableConnection(DBMSSQLAuthenticatorDelegateImpl.java:923)
at weblogic.security.providers.authentication.DBMSSQLAuthenticatorDelegateImpl.validateConfiguration(DBMSSQLAuthenticatorDelegateImpl.java:153)
at weblogic.security.providers.authentication.DBMSSQLAuthenticatorDelegateImpl.<init>(DBMSSQLAuthenticatorDelegateImpl.java:78)
at weblogic.security.providers.authentication.DBMSAuthenticatorDelegateImpl.getInstance(DBMSAuthenticatorDelegateImpl.java:459)
at weblogic.security.providers.authentication.DBMSSQLAuthenticationProviderImpl.initialize(DBMSSQLAuthenticationProviderImpl.java:56)
at com.bea.common.security.internal.legacy.service.SecurityProviderImpl.init(SecurityProviderImpl.java:65)
at com.bea.common.engine.internal.ServiceEngineImpl.findOrStartService(ServiceEngineImpl.java:363)
at com.bea.common.engine.internal.ServiceEngineImpl.findOrStartService(ServiceEngineImpl.java:315)
at com.bea.common.engine.internal.ServiceEngineImpl.lookupService(ServiceEngineImpl.java:257)
at com.bea.common.engine.internal.ServicesImpl.getService(ServicesImpl.java:72)
at weblogic.security.service.internal.WLSIdentityServiceImpl.initialize(Unknown Source)
at weblogic.security.service.CSSWLSDelegateImpl.initializeServiceEngine(Unknown Source)
at weblogic.security.service.CSSWLSDelegateImpl.initialize(Unknown Source)
at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.InitializeServiceEngine(Unknown Source)
at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.initializeRealm(Unknown Source)
at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.loadRealm(Unknown Source)
at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.initializeRealms(Unknown Source)
at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.initialize(Unknown Source)
at weblogic.security.service.SecurityServiceManager.initialize(Unknown Source)
at weblogic.security.SecurityService.start(SecurityService.java:141)
at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:173)


####<Sep 30, 2011 7:07:37 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389857978> <BEA-090075> <The SAMLIdentityAssertor provider has had its LDIF information loaded from: C:\bea\user_projects\domains\myPortalDomain\security\SAMLIdentityAssertorInit.ldift>
####<Sep 30, 2011 7:07:38 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389858245> <BEA-090851> <The SAMLIdentityAsserter provider is initialized.>
####<Sep 30, 2011 7:07:38 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389858920> <BEA-090516> <The CredentialMapper provider has preexisting LDAP data.>
####<Sep 30, 2011 7:07:39 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389859659> <BEA-090516> <The Authorizer provider has preexisting LDAP data.>
####<Sep 30, 2011 7:07:41 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389861370> <BEA-090075> <The SAMLCredentialMapper provider has had its LDIF information loaded from: C:\bea\user_projects\domains\myPortalDomain\security\SAMLCredentialMapperInit.ldift>
####<Sep 30, 2011 7:07:41 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389861480> <BEA-090851> <The SAMLCredentialMapperV2 provider is initialized.>
####<Sep 30, 2011 7:07:41 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389861559> <BEA-090516> <The CredentialMapper provider has preexisting LDAP data.>
####<Sep 30, 2011 7:07:41 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389861669> <BEA-090516> <The RoleMapper provider has preexisting LDAP data.>
####<Sep 30, 2011 7:07:42 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389862203> <BEA-090093> <No pre-WLS 8.1 Keystore providers are configured for server AdminServer for security realm myrealm.>
####<Sep 30, 2011 7:07:42 PM IST> <Notice> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389862203> <BEA-090082> <Security initializing using security realm myrealm.>
####<Sep 30, 2011 7:07:58 PM IST> <Error> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389878205> <BEA-000000> <[Security:090735]The DBMS connection was not usable>
####<Sep 30, 2011 7:07:58 PM IST> <Critical> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389878283> <BEA-090403> <Authentication for user weblogic denied>
####<Sep 30, 2011 7:07:58 PM IST> <Critical> <WebLogicServer> <AdminServer> <Main Thread> <<WLS Kernel>> <1317389878299> <BEA-000386> <Server subsystem failed. Reason: weblogic.security.SecurityInitializationException: Authentication for user weblogic denied
weblogic.security.SecurityInitializationException: Authentication for user weblogic denied
at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.doBootAuthorization(Unknown Source)
at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.initialize(Unknown Source)
at weblogic.security.service.SecurityServiceManager.initialize(Unknown Source)
at weblogic.security.SecurityService.start(SecurityService.java:141)
at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:173)

How to resolve this please?
Maneesh Godbole
Saloon Keeper

Joined: Jul 26, 2007
Posts: 9990
    
    7

Please do not post essentially the same question multiple times. Let us continue the discussion in the original topic
Please UseOneThreadPerQuestion


[How to ask questions] [Donate a pint, save a life!] [Onff-turn it on!]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Authentication for user weblogic denied
 
Similar Threads
Publishing failing - Changing to Republish mode :( Please help !!
Failed to start JMS Server
Timeout waiting for Oracle WebLogic Server v10.3 at localhost to start
Authentication for user weblogic denied
Change application state "Start Running" to "Active"