GeeCON Prague 2014*
The moose likes HTML, CSS and JavaScript and the fly likes IE 8 browser: javascript code thinks it's IE 6 or older Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Engineering » HTML, CSS and JavaScript
Bookmark "IE 8 browser: javascript code thinks it Watch "IE 8 browser: javascript code thinks it New topic
Author

IE 8 browser: javascript code thinks it's IE 6 or older

chris gar
Ranch Hand

Joined: Jul 20, 2002
Posts: 45
I have IE 8. I checked the "about" in IE to confirm.

The following code is being executed:


This code works fine when executed by Firefox AND it works fine when my colleagues run it with IE8. However, when I run it on my IE8, I get the alert "Your browser is too old."

Could I have had an issue in upgrading my IE? Are there some other methods that could help me troubleshoot?

Not sure what to do. You assistance is appreciated.
chris gar
Ranch Hand

Joined: Jul 20, 2002
Posts: 45
The answer:

IE >> Internet Options >> Make sure "Enable native XMLHTTP supoprt" is checked.

:facepalm:

Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61306
    
  66

Thanks for posting back with the solution.


[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
 
GeeCON Prague 2014
 
subject: IE 8 browser: javascript code thinks it's IE 6 or older