This week's giveaway is in the EJB and other Java EE Technologies forum.
We're giving away four copies of EJB 3 in Action and have Debu Panda, Reza Rahman, Ryan Cuprak, and Michael Remijan on-line!
See this thread for details.
The moose likes JBoss/WildFly and the fly likes JBoss 4.0.1 SP1 incompatible w/ Xalan 2.7.x Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "JBoss 4.0.1 SP1 incompatible w/ Xalan 2.7.x" Watch "JBoss 4.0.1 SP1 incompatible w/ Xalan 2.7.x" New topic
Author

JBoss 4.0.1 SP1 incompatible w/ Xalan 2.7.x

Kelly Dolan
Ranch Hand

Joined: Jan 08, 2002
Posts: 107
I'm in desperate need for a solution.

I'm working on an application that deploys in JBoss 4.0.1 SP1 and integrating with a 3rd party component that calls (org.w3c.dom.)Node.getTextContent(). On call of this method, my log files contain a NoSuchMethodError. I've determined that the JBoss lib/endorsed directory contains xml-apis.jar which defines the interface for the Node class and it does not define this method. I've also determined that this jar and the accompanying ones (e.g., xalan) are for Xalan 2.6.0.

I've tried upgrading these jar files to Xalan 2.7.x and on start I see boat loads of errors in my log file (e.g., various rar files do not deploy). I've tried the latest Xalan 2.7.1 jars from the Apache web site. I've also tried the Xalan 2.7.0 jars from the JBoss 4.0.5 distribution.

Has anyone ever successfully addressed this problem? What options do I have?

1. Upgrade to JBoss 4.0.5? I can ask but I can say with most certainty that this is NOT an option for me right now.
2. Wrap the integration w/ the 3rd party component in a command line application and call it from the server code? I'm sure this would work but it's not ideal, especially since I need to pass a lot of information back and forth to this 3rd party component.
3. Get JBoss 4.0.1 SP1 to work w/ an API that defines and implements Node.getTextContent()? How is this done?
4. Other?

I should add that I've also tried putting newer jars in the "lib" folder of the application's WAR file in hopes it would pick these up first but this did not work.

Thanks!
Kelly
 
 
subject: JBoss 4.0.1 SP1 incompatible w/ Xalan 2.7.x
 
Similar Threads
class loading issue in Jboss
error while invoking jndi list in jmx - console
Class Loading error
NoClassDefFoundError
Building a jar with dependancies.