Two Laptop Bag*
The moose likes Websphere and the fly likes Problem when running addNode.sh on a Remote Server Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "Problem when running addNode.sh on a Remote Server" Watch "Problem when running addNode.sh on a Remote Server" New topic
Author

Problem when running addNode.sh on a Remote Server

Brian Cullen
Greenhorn

Joined: Oct 10, 2011
Posts: 1
I am new to WebSphere and have run into the following issue with Websphere 7 on RHEL 5.3 64Bit;

I have installed a Deployment Manager on Server A and under this have registered a Node and Application Server on the same server. On a new Server B I have created a new Application Server however when I run the addNode.sh script providing the host and port for the Deployment Manager I get the following;

$ ./addNode.sh IEDUBBAR01 8879 -username ********* -password *********
ADMU0116I: Tool information is being logged in file
/opt/IBM/WebSphere/AppServer/profiles/IEDUBBAR02/logs/addNode.log
ADMU0128I: Starting tool with the IEDUBBAR02 profile
CWPKI0309I: All signers from remote keystore already exist in local keystore.
ADMU0001I: Begin federation of node IEDUBBAR02Node with Deployment Manager at
IEDUBBAR01:8879.
ADMU0009I: Successfully connected to Deployment Manager Server: IEDUBBAR01:8879
ADMU0505I: Servers found in configuration:
ADMU0506I: Server name: IEDUBBAR02
ADMU2010I: Stopping all server processes for node IEDUBBAR02Node
ADMU0510I: Server IEDUBBAR02 is now STOPPED
ADMU0024I: Deleting the old backup directory.
ADMU0015I: Backing up the original cell repository.
ADMU0012I: Creating Node Agent configuration for node: IEDUBBAR02Node
ADMU0014I: Adding node IEDUBBAR02Node configuration to cell: localhostCell01

ADMU0027E: An error occurred during federation Connection refused; rolling back
to original configuration.
ADMU0211I: Error details may be seen in the file:
/opt/IBM/WebSphere/AppServer/profiles/IEDUBBAR02/logs/addNode.log
ADMU0026I: An error occurred during federation; rolling back to original
configuration.
ADMU0113E: Program exiting with error:
com.ibm.websphere.management.exception.AdminException:
com.ibm.websphere.management.filetransfer.client.TransferFailedException:
Upload retry limit exceeded for file /tmp/IEDUBBAR02Node__27598.car.
Exception: java.net.ConnectException: Connection refused, resulting
from: java.net.ConnectException: Connection refused
ADMU1211I: To obtain a full trace of the failure, use the -trace option.
ADMU0211I: Error details may be seen in the file:
/opt/IBM/WebSphere/AppServer/profiles/IEDUBBAR02/logs/addNode.log

In the addNode.log file the exception that is thrown is as follows;

[10/10/11 17:21:26:799 IST] 00000000 AdminTool A ADMU0026I: An error occurred during federation; rolling back to original configuration.
[10/10/11 17:21:27:597 IST] 00000000 AdminTool A ADMU0113E: Program exiting with error: com.ibm.websphere.management.exception.AdminException: com.ibm.websphere.management.filetransfer.client.TransferFailedException: Upload retry limit exceeded for file /tmp/IEDUBBAR02Node__27598.car. Exception: java.net.ConnectException: Connection refused
at com.ibm.ws.management.util.Utils.makeAdminException(Utils.java:331)
at com.ibm.ws.management.tools.NodeFederationUtility.runTool(NodeFederationUtility.java:551)
at com.ibm.ws.management.tools.AdminTool.executeUtility(AdminTool.java:269)
at com.ibm.ws.management.tools.NodeFederationUtility.main(NodeFederationUtility.java:297)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:45)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
at java.lang.reflect.Method.invoke(Method.java:599)
at com.ibm.wsspi.bootstrap.WSLauncher.launchMain(WSLauncher.java:213)
at com.ibm.wsspi.bootstrap.WSLauncher.main(WSLauncher.java:93)
at com.ibm.wsspi.bootstrap.WSLauncher.run(WSLauncher.java:74)
at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:78)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:92)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:68)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:177)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:45)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
at java.lang.reflect.Method.invoke(Method.java:599)
at org.eclipse.core.launcher.Main.invokeFramework(Main.java:340)
at org.eclipse.core.launcher.Main.basicRun(Main.java:282)
at org.eclipse.core.launcher.Main.run(Main.java:981)
at com.ibm.wsspi.bootstrap.WSPreLauncher.launchEclipse(WSPreLauncher.java:330)
at com.ibm.wsspi.bootstrap.WSPreLauncher.main(WSPreLauncher.java:108)

I have searched IBM support and Google'd this issue but cannot see a definitive answer to what might be causing the issue. I would appreciate and information / guidance that anyone has to help me resolved this problem.

 
jQuery in Action, 2nd edition
 
subject: Problem when running addNode.sh on a Remote Server