This week's giveaway is in the Spring forum.
We're giving away four copies of REST with Spring (video course) and have Eugen Paraschiv on-line!
See this thread for details.
The moose likes Tomcat and the fly likes Unable to open the service 'tomcat6' Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of REST with Spring (video course) this week in the Spring forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Unable to open the service Watch "Unable to open the service New topic

Unable to open the service 'tomcat6'

Berkan Sesen

Joined: Oct 04, 2011
Posts: 12

I have tried to run the tomcat6w.exe first on two different machines, one running Windows 7 and the other Windows XP SP2 and I get this error every time:

The specified service does not exist as an installed service.
Unable to open the service 'tomcat6'

I have googled this issue and could not find any clear solutions.
There are however two main solution suggestions, neither of which has worked for me:

1 - : This solution suggests copying the msvcr71.dll from %JAVA_HOME%\bin to %SYSTEM_ROOT%\system32 or any other location on the path. However, I am not missing this .dll in my system32 folder.
2 - : This solution suggests that it is because the windows user is not authorised to install system services. NOw, I have administrator privileges in both computers and furthermore one of them is my own laptop so I think I should not have privilege issues. This link alternatively suggests running the tomcat by the catalina.bat. However, when I click on the catalina.bat on both machines, a one line command prompt window flickers for half a second and disappears.

Initially, I was convinced that this may be an authorisation issue but after trying it on my own laptop and getting the same result, I think there is something else that is wrong.
Strangely, there is no clear solution for this on the web. Does anyone have any ideas?

P.S: I get the same error for tomcat7w.exe as well)

Charles Owen
Ranch Hand

Joined: Aug 31, 2009
Posts: 61
Try the Tomcat 6 documentation. Here's a topic that discusses this very issue:

Alternatively, you can just startup Tomcat via the command line or through a script:

1) Open the command line (run as administrator if necessary)
2) cd to your Tomcat installation bin directory
3) type startup.bat

Hope this helps,
Shobana Ns

Joined: Nov 02, 2011
Posts: 1
hi Charles,
I also got the same error message as Berkan got. Thank you for comment, now i can able to run tomcat
Don't get me started about those stupid light bulbs.
subject: Unable to open the service 'tomcat6'
It's not a secret anymore!