aspose file tools*
The moose likes IDEs, Version Control and other tools and the fly likes PWC6180: Unable to initialize TldLocationsCache in NetBeans Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "PWC6180: Unable to initialize TldLocationsCache in NetBeans" Watch "PWC6180: Unable to initialize TldLocationsCache in NetBeans" New topic
Author

PWC6180: Unable to initialize TldLocationsCache in NetBeans

Ashish R Srivastava
Greenhorn

Joined: Oct 18, 2011
Posts: 7

Hello Guru's,

I am running my project in NetBeans 6.8 with Tomcat 6. It's having the concept of Struts 1.3

I included following code on the topmost line of most of my JSP's :

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

After build, its highlighting with a Red line and pop up with following statement:

PWC6180: Unable to initialize TldLocationsCache


Please treat it as urgency, and help me to resolve this issue..!!

Thanks in advance..!!!


A new BEE in the world of JAVA.
Thanks in advance to the seniors for their kind Help..!!!
Ashish R Srivastava
Greenhorn

Joined: Oct 18, 2011
Posts: 7

For more reference, I am providing you some start lines of my JSP :

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<%@ page language="java" contentType="text/html; charset=UTF-8" %>
<%@ taglib uri="http://struts.apache.org/tags-bean" prefix="bean" %>
<%@ taglib uri="http://struts.apache.org/tags-html" prefix="html" %>
<%@ taglib uri="http://struts.apache.org/tags-logic" prefix="logic" %>
<%@ include file="ReadPropertiesFile.jsp" %>
<%@ include file="JSInclude.jsp" %>
olivier dutranoit
Ranch Hand

Joined: Aug 20, 2011
Posts: 81

Hi,

The error has nothing to do with your doctype...thats for you HTML.

don't you forget the *.tld extention?


<%@ taglib uri="http://struts.apache.org/tags-bean" prefix="bean" %>
should be
<%@ taglib uri="http://struts.apache.org/tags-bean.tld" prefix="bean" %>
Raghavan Muthu
Ranch Hand

Joined: Apr 20, 2006
Posts: 3344

You may have it urgent, but you should understand the basic understanding on the nature of forum and people.

No one is guaranteed to reply or solve your issue. At the max people can try their best, at their convenient time

Here is mine.

1. Read this link
2. More precisely, this link explains the issue.

Overall, as a summary what the poster in the other thread said was,


I have moved all the tld files from WEB-INF/tags to WEB-INF/tld and updated web.xml etc accordingly... this has solved precompilation issues.. and I am hoping it has solved the whole problem.


Try this and let us know.

All what I did was this


Everything has got its own deadline including one's EGO!
[CodeBarn] [Java Concepts-easily] [Corey's articles] [SCJP-SUN] [Servlet Examples] [Java Beginners FAQ] [Sun-Java Tutorials] [Java Coding Guidelines]
 
jQuery in Action, 2nd edition
 
subject: PWC6180: Unable to initialize TldLocationsCache in NetBeans