aspose file tools*
The moose likes Websphere and the fly likes WSadmin set sessionManagement (cookiePath) for WebModule doesn't work. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "WSadmin set sessionManagement (cookiePath) for WebModule doesn Watch "WSadmin set sessionManagement (cookiePath) for WebModule doesn New topic
Author

WSadmin set sessionManagement (cookiePath) for WebModule doesn't work.

Geert Pante
Greenhorn

Joined: Feb 03, 2011
Posts: 8
Hi All,

I tried to configure session management for a Web Module as described in the InfoCenter.

Basically, all I need to do is set the cookiePath. So I do this:

This is saved correctly in ../deployment.xml:

However, after synchronizing and restarting the application server, the cookiepath is not used. If I open the sessionManagement in the web console, and save it without changes, the following gets saved:

And now the settings get applied correctly.

I saw there is a warning that you also need to set the tuningParams via wsadmin to get the sessionManagement to work, but that doesn't help:

The tuningParams got saved this time, but the cookiePath still didn't get applied :-(

Does anybody know what the required parameters are to set in wsadmin to get the sessionManagement to work?
Greets, Geert.
YouHeng Hu
Greenhorn

Joined: Jul 07, 2003
Posts: 2
Hi Geert,

I had the same issue using jython scripts to deploy applications. By comparing the deployment.xml generated from WAS admin console and the one generated from jython script, I found out the config id of the sessionMgr must be added to targetMappings to make the cookie path working.

You may find the sample code in <http://publib.boulder.ibm.com/infocenter/wasinfo/v8r0/index.jsp?topic=%2Fcom.ibm.websphere.nd.doc%2Finfo%2Fae%2Fae%2Ftxml_webmodules.html> useful.

HTH

Youheng


Geert Pante
Greenhorn

Joined: Feb 03, 2011
Posts: 8
Hi,

I did read the sample code in the infocenter, but indeed I missed the part about the targetMappings.
Didn't notice it in the XML either.

So it should be :


I'll try that when I have the opportunity to work with WebSphere again.

Thanks, Geert.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: WSadmin set sessionManagement (cookiePath) for WebModule doesn't work.