my dog learned polymorphism
The moose likes Servlets and the fly likes error in console Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Servlets
Bookmark "error in console" Watch "error in console" New topic

error in console

ganesan ayyanu

Joined: Oct 26, 2011
Posts: 3

this error shown in console how to solve this issue first i want to know why it is coming continiously...........................

java.lang.UnsupportedClassVersionError: Bad version number in .class file (unable to load class ser)
at org.apache.catalina.loader.WebappClassLoader.findClassInternal(
at org.apache.catalina.loader.WebappClassLoader.findClass(
at org.apache.catalina.loader.WebappClassLoader.loadClass(
at org.apache.catalina.loader.WebappClassLoader.loadClass(
at org.apache.catalina.startup.WebAnnotationSet.loadApplicationServletAnnotations(
at org.apache.catalina.startup.WebAnnotationSet.loadApplicationAnnotations(
at org.apache.catalina.startup.ContextConfig.applicationAnnotationsConfig(
at org.apache.catalina.startup.ContextConfig.start(
at org.apache.catalina.startup.ContextConfig.lifecycleEvent(
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(
at org.apache.catalina.core.StandardContext.start(
at org.apache.catalina.core.ContainerBase.addChildInternal(
at org.apache.catalina.core.ContainerBase.addChild(
at org.apache.catalina.core.StandardHost.addChild(
at org.apache.catalina.startup.HostConfig.deployDescriptor(
at org.apache.catalina.startup.HostConfig.deployDescriptors(
at org.apache.catalina.startup.HostConfig.deployApps(
at org.apache.catalina.startup.HostConfig.check(
at org.apache.catalina.startup.HostConfig.lifecycleEvent(
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(
at org.apache.catalina.core.ContainerBase.backgroundProcess(
at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(
at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(
at org.apache.catalina.core.ContainerBase$
at Source)
Saifuddin Merchant
Ranch Hand

Joined: Feb 08, 2009
Posts: 607

Google? java.lang.UnsupportedClassVersionError

Cheers - Sam.
Twisters - The new age Java Quiz || My Blog
Sunil Sunny
Ranch Hand

Joined: Oct 18, 2011
Posts: 41
this error usually occurs when a higher version of Java Compiler is used to generate the ".class file" than the JVM version which is used to execute that class file. So do not worry just download a "jdk1.7 full with Jre"(latest release) and compile your ".java file " again it will work .
William Brogden
Author and all-around good cowpoke

Joined: Mar 22, 2000
Posts: 13037
Alternate approach - you can compile with "target" option to generate a class file which will be accepted by the older JVM.

Sunil Sunny
Ranch Hand

Joined: Oct 18, 2011
Posts: 41
William Brogden wrote:Alternate approach - you can compile with "target" option to generate a class file which will be accepted by the older JVM.


yes, but that too is possible with higher vesion compiler.
I agree. Here's the link:
subject: error in console
jQuery in Action, 3rd edition